aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2015-01-22 09:35:22 +0000
committerJohn Crispin <blogic@openwrt.org>2015-01-22 09:35:22 +0000
commit89329096dfb166cb55a7850997e21db0e377b103 (patch)
tree180cd16cb94b761be64ff8411dbca77454137ffd /target/linux/ramips/image
parent35d648cb2e6290899e37b50302c88e676452f402 (diff)
downloadupstream-89329096dfb166cb55a7850997e21db0e377b103.tar.gz
upstream-89329096dfb166cb55a7850997e21db0e377b103.tar.bz2
upstream-89329096dfb166cb55a7850997e21db0e377b103.zip
ramips: add support for Tenda 3G150B
Add suport for Tenda 3G150B: - cpu: Ralink RT5350F - flash: 4MB - ram: 32MB - 1x USB 2.0 - 1x RJ45 - one reset button - battery powered (BP-4L, 3.7V 1450mAh) Signed-off-by: Cezary Jackiewicz <cezary.jackiewicz@gmail.com> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@44073 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ramips/image')
-rw-r--r--target/linux/ramips/image/Makefile3
1 files changed, 3 insertions, 0 deletions
diff --git a/target/linux/ramips/image/Makefile b/target/linux/ramips/image/Makefile
index e4dea9b7b5..d35c4206b8 100644
--- a/target/linux/ramips/image/Makefile
+++ b/target/linux/ramips/image/Makefile
@@ -549,6 +549,8 @@ Image/Build/Profile/M4=$(call BuildFirmware/PorayDualSize/$(1),$(1),m4,M4)
Image/Build/Profile/MOFI3500-3GN=$(call BuildFirmware/Default8M/$(1),$(1),mofi3500-3gn,MOFI3500-3GN)
# Kernel name should be "Linux Kernel Image" to make the OpenWrt image installable from factory Web UI
+Image/Build/Profile/3G150B=$(call BuildFirmware/Default4M/$(1),$(1),3g150b,3G150B,Linux Kernel Image)
+
Image/Build/Profile/MPRA1=$(call BuildFirmware/Default4M/$(1),$(1),mpr-a1,MPRA1,Linux Kernel Image)
Image/Build/Profile/MPRA2=$(call BuildFirmware/Default8M/$(1),$(1),mpr-a2,MPRA2,Linux Kernel Image)
@@ -676,6 +678,7 @@ ifeq ($(SUBTARGET),rt305x)
define Image/Build/Profile/Default
$(call Image/Build/Profile/3G6200N,$(1))
$(call Image/Build/Profile/3G6200NL,$(1))
+ $(call Image/Build/Profile/3G150B,$(1))
$(call Image/Build/Profile/3G300M,$(1))
$(call Image/Build/Profile/A5-11,$(1))
$(call Image/Build/Profile/AIR3GII,$(1))