aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image
diff options
context:
space:
mode:
authorWeijie Gao <hackpascal@gmail.com>2018-12-09 02:55:56 +0800
committerMathias Kresin <dev@kresin.me>2018-12-28 12:45:23 +0100
commit74af8a833a00da6cc8b6bbd0993917ab717f7d54 (patch)
treef52618e48b873e83b1fa0e3d81895aac39baf6b2 /target/linux/ramips/image
parentd020ae79ab65a291e53a52a94985b4ab42a30541 (diff)
downloadupstream-74af8a833a00da6cc8b6bbd0993917ab717f7d54.tar.gz
upstream-74af8a833a00da6cc8b6bbd0993917ab717f7d54.tar.bz2
upstream-74af8a833a00da6cc8b6bbd0993917ab717f7d54.zip
ramips: add support for CreativeBox v1
Hardware: SoC: MT7621 DRAM: 512MB DDR3 Flash: 32MB SPI-NOR WiFi 2.4GHz: MT7603 @ PCIe0 WiFi 5.8GHz: MT7612 @ PCIe1 SATA: ASM1061 @ PCIe2 Interfaces: GBE RJ45 x5 USB3.0 x1 eSATA (with USB2.0) x1 SATA x1 UART x1 I2C x1 JTAG x1 Flash instructions: Through factory bootloader or firmware web interface Signed-off-by: Weijie Gao <hackpascal@gmail.com>
Diffstat (limited to 'target/linux/ramips/image')
-rw-r--r--target/linux/ramips/image/mt7621.mk10
1 files changed, 10 insertions, 0 deletions
diff --git a/target/linux/ramips/image/mt7621.mk b/target/linux/ramips/image/mt7621.mk
index d4c9a100ed..cb86bad9ce 100644
--- a/target/linux/ramips/image/mt7621.mk
+++ b/target/linux/ramips/image/mt7621.mk
@@ -121,6 +121,16 @@ define Device/mediatek_ap-mt7621a-v60
endef
TARGET_DEVICES += mediatek_ap-mt7621a-v60
+define Device/xzwifi_creativebox-v1
+ DTS := CreativeBox-v1
+ IMAGE_SIZE := $(ralink_default_fw_size_32M)
+ DEVICE_TITLE := CreativeBox v1
+ DEVICE_PACKAGES := \
+ kmod-ata-core kmod-ata-ahci kmod-mt7603 kmod-mt76x2 kmod-sdhci-mt7620 \
+ kmod-usb3
+endef
+TARGET_DEVICES += xzwifi_creativebox-v1
+
define Device/elecom_wrc-1167ghbk2-s
DTS := WRC-1167GHBK2-S
IMAGE_SIZE := 15488k