aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image
diff options
context:
space:
mode:
authorJan-Niklas Burfeind <git@aiyionpri.me>2022-12-07 19:12:14 +0100
committerDavid Bauer <mail@david-bauer.net>2022-12-09 00:19:44 +0100
commit6cd1035d8dc001561331ca9e613d7dfc7d0fd7a6 (patch)
tree27f990742441ef8ae96fdf494582b799e4439a04 /target/linux/ramips/image
parent3f7ce4bd4040aab2ff9fa38a5b00c26851341b75 (diff)
downloadupstream-6cd1035d8dc001561331ca9e613d7dfc7d0fd7a6.tar.gz
upstream-6cd1035d8dc001561331ca9e613d7dfc7d0fd7a6.tar.bz2
upstream-6cd1035d8dc001561331ca9e613d7dfc7d0fd7a6.zip
ramips: add support for Wavlink WS-WN572HP3 4G
Wavlink WS-WN572HP3 4G is an 802.11ac dual-band outdoor router with LTE support. Specifications; * Soc: MT7621DAT * RAM: 128MiB * Flash: NOR 16MiB GD-25Q128ESIG3 * Wi-Fi: * MT7613BEN: 5GHz * MT7603EN: 2.4GHz * Ethernet: 2x 1GbE * USB: None - only used internally * LTE Modem: Quectel EC200T-EU * UART: 115200 baud * LEDs: * 7 blue at the front * 1 Power * 2 LAN / WAN * 1 Status * 3 RSSI (annotated 4G) * 1 green at the bottom (4G LED) * Buttons: 1 reset button Installation: * press and hold the reset button while powering on the device * keep it pressed for ten seconds * connect to 192.168.10.1 via webbrowser (chromium/chrome works, at least Firefox 106.0.3 does not) * upload the sysupgrade image, confirm the checksum, wait 2 minutes until the device reboots Revert to stock firmware: * same as installation but use the recovery image for WL-WN572HP3 Signed-off-by: Jan-Niklas Burfeind <git@aiyionpri.me> Acked-by: Arınç ÜNAL <arinc.unal@arinc9.com> (cherry picked from commit dce66899bf243d78689afcc693340b891bbf4c2d)
Diffstat (limited to 'target/linux/ramips/image')
-rw-r--r--target/linux/ramips/image/mt7621.mk17
1 files changed, 17 insertions, 0 deletions
diff --git a/target/linux/ramips/image/mt7621.mk b/target/linux/ramips/image/mt7621.mk
index 2907d90dab..961f8a3b75 100644
--- a/target/linux/ramips/image/mt7621.mk
+++ b/target/linux/ramips/image/mt7621.mk
@@ -1878,6 +1878,23 @@ define Device/wavlink_wl-wn533a8
endef
TARGET_DEVICES += wavlink_wl-wn533a8
+define Device/wavlink_ws-wn572hp3-4g
+ $(Device/dsa-migration)
+ BLOCKSIZE := 64k
+ DEVICE_VENDOR := Wavlink
+ DEVICE_MODEL := WS-WN572HP3
+ DEVICE_VARIANT := 4G
+ IMAGE_SIZE := 15040k
+ KERNEL_LOADADDR := 0x82000000
+ KERNEL := kernel-bin | relocate-kernel 0x80001000 | lzma | \
+ fit lzma $$(KDIR)/image-$$(firstword $$(DEVICE_DTS)).dtb
+ IMAGE/sysupgrade.bin := append-kernel | pad-to $$$$(BLOCKSIZE) | \
+ append-rootfs | pad-rootfs | check-size | append-metadata
+ DEVICE_PACKAGES := kmod-mt7603 kmod-mt7615e kmod-mt7663-firmware-ap \
+ kmod-usb3 kmod-usb-net-rndis comgt-ncm
+endef
+TARGET_DEVICES += wavlink_ws-wn572hp3-4g
+
define Device/wevo_11acnas
$(Device/dsa-migration)
$(Device/uimage-lzma-loader)