aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image
diff options
context:
space:
mode:
authorCarlo Nel <carlojnel@gmail.com>2018-08-26 21:11:59 +0200
committerMathias Kresin <dev@kresin.me>2018-09-06 21:36:42 +0200
commit6bbb2202551be394fead2efd99eb946f846fc63d (patch)
treedc03da1873c1ca5c73d08f3451599c383c8f275e /target/linux/ramips/image
parent9c26def64ad9891a036dcabcde11d58ecd59e8f4 (diff)
downloadupstream-6bbb2202551be394fead2efd99eb946f846fc63d.tar.gz
upstream-6bbb2202551be394fead2efd99eb946f846fc63d.tar.bz2
upstream-6bbb2202551be394fead2efd99eb946f846fc63d.zip
ramips: add support for TP-Link TL-MR3020 v3
TP-Link TL-MR3020 v3 is a pocket-size router based on MediaTek MT7628N. This PR is based on the work of @meyergru[1], with his permission. Specification: - MediaTek MT7628N/N (575 Mhz) - 64 MB of RAM - 8 MB of FLASH - 2T2R 2.4 GHz - 1x 10/100 Mbps Ethernet Flash instruction: The only way to flash the image in TL-MR3020 v3 is to use tftp recovery mode in U-Boot: 1. Configure PC with static IP 192.168.0.225/24 and tftp server. 2. Rename "openwrt-ramips-mt76x8-tplink_tl-mr3020-v3-squashfs-tftp-recovery.bin" to "tp_recovery.bin" and place it in tftp server directory. 3. Connect PC with the LAN port, press the reset button, power up the router and keep button pressed for around 6-7 seconds, until device starts downloading the file. 4. Router will download file from server, write it to flash and reboot. [1] https://github.com/meyergru/lede-source/commits/TL-MR3020-V3 Signed-off-by: Carlo Nel <carlojnel@gmail.com>
Diffstat (limited to 'target/linux/ramips/image')
-rw-r--r--target/linux/ramips/image/mt76x8.mk14
1 files changed, 14 insertions, 0 deletions
diff --git a/target/linux/ramips/image/mt76x8.mk b/target/linux/ramips/image/mt76x8.mk
index 0c657d5a0f..15bc1ee703 100644
--- a/target/linux/ramips/image/mt76x8.mk
+++ b/target/linux/ramips/image/mt76x8.mk
@@ -231,6 +231,20 @@ define Device/tplink_c50-v3
endef
TARGET_DEVICES += tplink_c50-v3
+define Device/tplink_tl-mr3020-v3
+ $(Device/tplink)
+ DTS := TL-MR3020V3
+ IMAGE_SIZE := 7808k
+ DEVICE_TITLE := TP-Link TL-MR3020 v3
+ TPLINK_FLASHLAYOUT := 8Mmtk
+ TPLINK_HWID := 0x30200003
+ TPLINK_HWREV := 0x3
+ TPLINK_HWREVADD := 0x3
+ TPLINK_HVERSION := 3
+ DEVICE_PACKAGES := kmod-usb2 kmod-usb-ohci kmod-usb-ledtrig-usbport
+endef
+TARGET_DEVICES += tplink_tl-mr3020-v3
+
define Device/tplink_tl-mr3420-v5
$(Device/tplink)
DTS := TL-MR3420V5