aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image
diff options
context:
space:
mode:
authorAnton Arapov <arapov@gmail.com>2018-12-29 01:28:27 +0100
committerMathias Kresin <dev@kresin.me>2019-01-05 12:28:22 +0100
commit52f2d7d2a9dc3e142bb957462a30806eb5cebaf4 (patch)
treeee2f1c8361272cedff87f220d059c3a0093425fb /target/linux/ramips/image
parenta54129d8aa62e63d2e1ab483cf67411d144f19d9 (diff)
downloadupstream-52f2d7d2a9dc3e142bb957462a30806eb5cebaf4.tar.gz
upstream-52f2d7d2a9dc3e142bb957462a30806eb5cebaf4.tar.bz2
upstream-52f2d7d2a9dc3e142bb957462a30806eb5cebaf4.zip
ramips: add RB750Gr3 native support
This patch adds support of MikroTik RouterBOARD 750Gr3, without the need to reflashing the bootloader. Installation through RouterBoot follows the usual MikroTik method https://openwrt.org/toh/mikrotik/common Since the image isn't compatible with RouterBOARD 750Gr3 installations which have replaced the bootloader, the former used userspace boardname is not added to the SUPPORTED_DEVICES, to prevent a brick while trying to upgrade to the image with native support. Signed-off-by: Anton Arapov <arapov@gmail.com> Signed-off-by: Thibaut VARĂˆNE <hacks@slashdirt.org> Signed-off-by: Mathias Kresin <dev@kresin.me>
Diffstat (limited to 'target/linux/ramips/image')
-rw-r--r--target/linux/ramips/image/mt7621.mk15
1 files changed, 7 insertions, 8 deletions
diff --git a/target/linux/ramips/image/mt7621.mk b/target/linux/ramips/image/mt7621.mk
index 0edc8afcae..3f0c4bb76e 100644
--- a/target/linux/ramips/image/mt7621.mk
+++ b/target/linux/ramips/image/mt7621.mk
@@ -324,14 +324,6 @@ define Device/netgear_r6350
endef
TARGET_DEVICES += netgear_r6350
-define Device/rb750gr3
- DTS := RB750Gr3
- IMAGE_SIZE := $(ralink_default_fw_size_16M)
- DEVICE_TITLE := MikroTik RB750Gr3
- DEVICE_PACKAGES := kmod-usb3 uboot-envtools
-endef
-TARGET_DEVICES += rb750gr3
-
define Device/MikroTik
BLOCKSIZE := 64k
IMAGE_SIZE := 16128k
@@ -343,6 +335,13 @@ define Device/MikroTik
append-rootfs | pad-rootfs | append-metadata | check-size $$$$(IMAGE_SIZE)
endef
+define Device/mikrotik_rb750gr3
+ $(Device/MikroTik)
+ DTS := RB750Gr3
+ DEVICE_TITLE := MikroTik RouterBOARD RB750Gr3
+endef
+TARGET_DEVICES += mikrotik_rb750gr3
+
define Device/mikrotik_rbm33g
$(Device/MikroTik)
DTS := RBM33G