aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image
diff options
context:
space:
mode:
authorPawel Dembicki <paweldembicki@gmail.com>2020-04-17 22:31:11 +0200
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-05-09 20:02:17 +0200
commit426fb8cf84ae19b0edc2ed06f7a595bc7b1ed212 (patch)
tree38349f224413534aff2485e2615985162288aaf6 /target/linux/ramips/image
parenta8a1ef856871dc8403ea9c0a3bb347c7120b0e65 (diff)
downloadupstream-426fb8cf84ae19b0edc2ed06f7a595bc7b1ed212.tar.gz
upstream-426fb8cf84ae19b0edc2ed06f7a595bc7b1ed212.tar.bz2
upstream-426fb8cf84ae19b0edc2ed06f7a595bc7b1ed212.zip
ramips: add support for LB-Link BL-W1200
The BL-W1200 Wireless Router is based on the MT7620A SoC. Specification: - MediaTek MT7620A (580 Mhz) - 64 MB of RAM - 8 MB of FLASH - 1x 802.11bgn radio - 1x 802.11ac radio (MT7612E) - 5x 10/100/1000 Mbps Ethernet (MT7530) - 2x external, non-detachable antennas (Wifi 2.4G/5G) - 1x USB 2.0 - UART (R2) on PCB (57600 8n1) - 9x LED (1 GPIO controlled), 1x button - u-Boot bootloader Known issues: - No status LED. Used WPS LED during boot/failsafe/sysupgrade. Installation: 1. Apply initramfs image via factory web-gui. 2. Install sysupgrade image. How to revert to OEM firmware: - sysupgrade -n -F stock_firmware.bin Reviewed-by: Sungbo Eo <mans0n@gorani.run> Signed-off-by: Pawel Dembicki <paweldembicki@gmail.com>
Diffstat (limited to 'target/linux/ramips/image')
-rw-r--r--target/linux/ramips/image/mt7620.mk9
1 files changed, 9 insertions, 0 deletions
diff --git a/target/linux/ramips/image/mt7620.mk b/target/linux/ramips/image/mt7620.mk
index 5e281f307d..4f5341f06e 100644
--- a/target/linux/ramips/image/mt7620.mk
+++ b/target/linux/ramips/image/mt7620.mk
@@ -579,6 +579,15 @@ define Device/lava_lr-25g001
endef
TARGET_DEVICES += lava_lr-25g001
+define Device/lb-link_bl-w1200
+ SOC := mt7620a
+ DEVICE_VENDOR := LB-Link
+ DEVICE_MODEL := BL-W1200
+ IMAGE_SIZE := 7872k
+ DEVICE_PACKAGES := kmod-usb2 kmod-usb-ohci kmod-mt76x2
+endef
+TARGET_DEVICES += lb-link_bl-w1200
+
define Device/lenovo_newifi-y1
SOC := mt7620a
IMAGE_SIZE := 16064k