aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image
diff options
context:
space:
mode:
authorHanqing Wong <hquu@outlook.com>2017-03-11 15:44:33 +0800
committerMathias Kresin <dev@kresin.me>2017-03-12 09:28:05 +0100
commit38bee61dab029a7608088f64da71c19cfc8cf267 (patch)
treeb54962eab8dc64eb7976bc1c37348c0577b81791 /target/linux/ramips/image
parent562484f25c535ef01a004d11b23243a36bcc50c9 (diff)
downloadupstream-38bee61dab029a7608088f64da71c19cfc8cf267.tar.gz
upstream-38bee61dab029a7608088f64da71c19cfc8cf267.tar.bz2
upstream-38bee61dab029a7608088f64da71c19cfc8cf267.zip
ramips: add support for Netgear R6220
This patch adds support for the Netgear R6220, aka Netgear AC1200 and R6220-100NAS. Specification: - SoC: MediaTek MT7621ST (880 MHz) - Falsh: 128 MiB (Macronix MX30LF1G08AA-TI) - RAM: 128 MiB (Nanya NT5CB64M16FP-DH) - Wireless: MediaTek MT7603EN b/g/n , MediaTek MT7612EN an+ac - LAN speed: 10/100/1000 - LAN ports: 4 - WAN speed: 10/100/1000 - WAN ports: 1 - Serial baud rate of Bootloader and factory firmware: 57600 Installation through telnet: - Copy kernel.bin and rootfs.bin to a USB flash disk, plug to usb port on the router. - Enable telnet with link: http://192.168.1.1/setup.cgi?todo=debug (login if required, default: admin password) - You will see "Debug Enabled!" - Telnet 192.168.1.1 and login with "root" - ls /mnt/shares/ to find out path of your USB disk. 'myUdisk' for example. - cd /mnt/shares/myUdisk - mtd_write write rootfs.bin Rootfs - mtd_write write kernel.bin Kernel - reboot nmrpflash can be used to recover to the netgear firmware if a broken image was flashed. Signed-off-by: Hanqing Wong <hquu@outlook.com>
Diffstat (limited to 'target/linux/ramips/image')
-rw-r--r--target/linux/ramips/image/mt7621.mk17
1 files changed, 17 insertions, 0 deletions
diff --git a/target/linux/ramips/image/mt7621.mk b/target/linux/ramips/image/mt7621.mk
index 6704f84dc5..a90cf17aa4 100644
--- a/target/linux/ramips/image/mt7621.mk
+++ b/target/linux/ramips/image/mt7621.mk
@@ -118,6 +118,23 @@ define Device/pbr-m1
endef
TARGET_DEVICES += pbr-m1
+define Device/r6220
+ DTS := R6220
+ BLOCKSIZE := 128k
+ PAGESIZE := 2048
+ KERNEL_SIZE := 4096k
+ KERNEL := $(KERNEL_DTB) | uImage lzma
+ IMAGE_SIZE := 28672k
+ UBINIZE_OPTS := -E 5
+ IMAGES := sysupgrade.tar kernel.bin rootfs.bin
+ IMAGE/sysupgrade.tar := sysupgrade-tar | append-metadata
+ IMAGE/kernel.bin := append-kernel
+ IMAGE/rootfs.bin := append-ubi | check-size $$$$(IMAGE_SIZE)
+ DEVICE_TITLE := Netgear R6220
+ DEVICE_PACKAGES := kmod-usb2 kmod-mt76
+endef
+TARGET_DEVICES += r6220
+
define Device/rb750gr3
DTS := RB750Gr3
IMAGE_SIZE := $(ralink_default_fw_size_16M)