aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image
diff options
context:
space:
mode:
authorVitaly Chekryzhev <13hakta@gmail.com>2016-10-29 17:26:58 +0500
committerMathias Kresin <dev@kresin.me>2016-11-18 08:54:57 +0100
commit348344874c8aaaeabd291eef0e45660f0c6aba95 (patch)
treea3ff58c591a8316f0e6bbfb2bdab418f05d69c86 /target/linux/ramips/image
parenta4814c744ce4aae6fbf62621d9c62476ca5ce28d (diff)
downloadupstream-348344874c8aaaeabd291eef0e45660f0c6aba95.tar.gz
upstream-348344874c8aaaeabd291eef0e45660f0c6aba95.tar.bz2
upstream-348344874c8aaaeabd291eef0e45660f0c6aba95.zip
ramips: add support for ZyXEL Keenetic Viva
Factory image can be installed via Zyxel WebUI. Signed-off-by: Vitaly Chekryzhev <13hakta@gmail.com> [removed linux,modalias parameter from flash node in dts] [removed sdhci node from dts; no sd card slot here] Signed-off-by: Mathias Kresin <dev@kresin.me>
Diffstat (limited to 'target/linux/ramips/image')
-rw-r--r--target/linux/ramips/image/mt7620.mk14
1 files changed, 14 insertions, 0 deletions
diff --git a/target/linux/ramips/image/mt7620.mk b/target/linux/ramips/image/mt7620.mk
index 35c94fee8b..e669b8c9ca 100644
--- a/target/linux/ramips/image/mt7620.mk
+++ b/target/linux/ramips/image/mt7620.mk
@@ -37,6 +37,10 @@ define Build/elecom-header
$(STAGING_DIR_HOST)/bin/tar -cf $@ -C $(KDIR) v_0.0.0.bin v_0.0.0.md5
endef
+define Build/zyimage
+ $(STAGING_DIR_HOST)/bin/zyimage $(1) $@
+endef
+
define Device/ArcherC20i
DTS := ArcherC20i
KERNEL := $(KERNEL_DTB)
@@ -418,3 +422,13 @@ define Device/dch-m225
DEVICE_PACKAGES := kmod-mt76
endef
TARGET_DEVICES += dch-m225
+
+define Device/kng_rc
+ DTS := kng_rc
+ IMAGE_SIZE := $(ralink_default_fw_size_16M)
+ DEVICE_TITLE := ZyXEL Keenetic Viva
+ DEVICE_PACKAGES := kmod-usb2 kmod-usb-ohci kmod-usb-ledtrig-usbport kmod-switch-rtl8366-smi kmod-switch-rtl8367b
+ IMAGES += factory.bin
+ IMAGE/factory.bin := $$(IMAGE/sysupgrade.bin) | zyimage -d 8997 -v "ZyXEL Keenetic Viva"
+endef
+TARGET_DEVICES += kng_rc