aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image
diff options
context:
space:
mode:
authorWonJung Kim <git@won-jung.kim>2021-12-22 15:59:00 +0900
committerChristian Lamparter <chunkeey@gmail.com>2021-12-29 20:35:57 +0100
commit2dde2416e1a2f7a3208095e29c20132ed9910889 (patch)
treee403aff89ba9c07f4c4ce50defd7d02f2102f069 /target/linux/ramips/image
parent482a7e23a44c23ea6c6a22e3ea97eb3bf94e70d1 (diff)
downloadupstream-2dde2416e1a2f7a3208095e29c20132ed9910889.tar.gz
upstream-2dde2416e1a2f7a3208095e29c20132ed9910889.tar.bz2
upstream-2dde2416e1a2f7a3208095e29c20132ed9910889.zip
ramips: add support for ipTIME A3004T
ipTIME A3004T is a 2.4/5GHz band router, based on Mediatek MT7621. Specifications: - SoC: MT7621 (880MHz) - RAM: DDR3 256M - Flash: NAND 128MB (Macronix NAND 128MiB 3,3V 8-bit) - WiFi: - 2.4GHz: MT7615E - 5GHz : MT7615E - Ethernet: - 4x LAN - 1x WAN - USB: 1 * USB3.0 port - UART: - 3.3V, TX, RX, GND / 57600 8N1 Installation via web interface: 1. Flash initramfs image using OEM's Recovery mode 2. Boot into OpenWrt and perform sysupgrade with sysupgrade image. Revert to stock firmware: - Flash stock firmware via OEM's Recovery mode How to use OEM's Recovery mode: 1. Power up with holding down the reset key until CPU LED stop blinking. 2. Set fixed ip with `192.168.0.2` with subnet mask `255.255.255.0` 3. Flash image via tftp to `192.168.0.1` Additional Notes: This router shares one MT7915E chip for both 2.4Ghz/5Ghz. radio0 will not working on 5Ghz as it's not connected to the antenna. Signed-off-by: WonJung Kim <git@won-jung.kim> (added led dt-bindings) Signed-off-by: Christian Lamparter <chunkeey@gmail.com>
Diffstat (limited to 'target/linux/ramips/image')
-rw-r--r--target/linux/ramips/image/mt7621.mk17
1 files changed, 17 insertions, 0 deletions
diff --git a/target/linux/ramips/image/mt7621.mk b/target/linux/ramips/image/mt7621.mk
index 35c5627264..e1cb0195b0 100644
--- a/target/linux/ramips/image/mt7621.mk
+++ b/target/linux/ramips/image/mt7621.mk
@@ -766,6 +766,23 @@ define Device/iptime_a3004ns-dual
endef
TARGET_DEVICES += iptime_a3004ns-dual
+define Device/iptime_a3004t
+ $(Device/dsa-migration)
+ $(Device/uimage-lzma-loader)
+ BLOCKSIZE := 128k
+ PAGESIZE := 2048
+ FILESYSTEMS := squashfs
+ KERNEL_SIZE := 4096k
+ IMAGE_SIZE := 129280k
+ UIMAGE_NAME := a3004t
+ UBINIZE_OPTS := -E 5
+ IMAGE/sysupgrade.bin := sysupgrade-tar | append-metadata
+ DEVICE_VENDOR := ipTIME
+ DEVICE_MODEL := A3004T
+ DEVICE_PACKAGES := kmod-mt7615e kmod-mt7615-firmware kmod-usb3
+endef
+TARGET_DEVICES += iptime_a3004t
+
define Device/iptime_a6ns-m
$(Device/dsa-migration)
IMAGE_SIZE := 16128k