aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image
diff options
context:
space:
mode:
authorDale Hui <strokes-races0b@icloud.com>2021-09-25 21:07:58 -0700
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2021-09-26 15:15:36 +0200
commit16fc409e7af03b53adca7c77c3a966d650933b79 (patch)
tree0eccdf4d1765d6f26dd76601951a5343285a1b58 /target/linux/ramips/image
parent95807f89ff6278a6c226eba3e6aadd123322f705 (diff)
downloadupstream-16fc409e7af03b53adca7c77c3a966d650933b79.tar.gz
upstream-16fc409e7af03b53adca7c77c3a966d650933b79.tar.bz2
upstream-16fc409e7af03b53adca7c77c3a966d650933b79.zip
ramips: add support for Netgear R6900v2
Netgear R6900v2 is a clone of Netgear R6700v2 Specifications ============== SoC: MediaTek MT7621AT RAM: 256M DDR3 FLASH: 128M NAND WiFi: MediaTek MT7615N an+ac MediaTek MT7615N bgn ETH: MediaTek MT7621AT BTN: 1x Connect (WPS), 1x WLAN, 1x Reset LED: Power (white/amber), WAN(white/amber), 2.4G(white), 5G(white), USB(white) , GuestWifi(white) 4x LAN(white/amber), Wifi Button(white), WPS Button(white) Flash Instructions ================== Login to netgear webinterface and flash factory.img Signed-off-by: Dale Hui <strokes-races0b@icloud.com>
Diffstat (limited to 'target/linux/ramips/image')
-rw-r--r--target/linux/ramips/image/mt7621.mk13
1 files changed, 13 insertions, 0 deletions
diff --git a/target/linux/ramips/image/mt7621.mk b/target/linux/ramips/image/mt7621.mk
index 523d58101a..d637705a1b 100644
--- a/target/linux/ramips/image/mt7621.mk
+++ b/target/linux/ramips/image/mt7621.mk
@@ -1101,6 +1101,19 @@ define Device/netgear_r6850
endef
TARGET_DEVICES += netgear_r6850
+define Device/netgear_r6900-v2
+ $(Device/netgear_sercomm_nand)
+ DEVICE_MODEL := R6900
+ DEVICE_VARIANT := v2
+ SERCOMM_HWNAME := R6950
+ SERCOMM_HWID := BZV
+ SERCOMM_HWVER := A001
+ SERCOMM_SWVER := 0x1032
+ IMAGE_SIZE := 40960k
+ DEVICE_PACKAGES += kmod-mt7615e kmod-mt7615-firmware
+endef
+TARGET_DEVICES += netgear_r6900-v2
+
define Device/netgear_r7200
$(Device/netgear_sercomm_nand)
DEVICE_MODEL := R7200