aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image
diff options
context:
space:
mode:
authorGiuseppe Lippolis <giu.lippolis@gmail.com>2018-04-05 18:01:41 +0200
committerMathias Kresin <dev@kresin.me>2018-04-08 09:51:06 +0200
commit1680ae7eae2602dd85463a71f88d0012b236bff7 (patch)
tree540925cfcf39b4ee4efa9bdc98e7e00beff5e4f2 /target/linux/ramips/image
parentcb7ac151cd13ca510588b80c24645f2add1b3737 (diff)
downloadupstream-1680ae7eae2602dd85463a71f88d0012b236bff7.tar.gz
upstream-1680ae7eae2602dd85463a71f88d0012b236bff7.tar.bz2
upstream-1680ae7eae2602dd85463a71f88d0012b236bff7.zip
ramips: add dwr-512 jboot firmware configuration
The previous fw version require the replacement of the stock bootloader with u-boot. This prevent an easy stock restore of the original fw. Now a proper fw util has been developed to manage the stock jboot bootloader. Therefore make sense have a fw image for the stock bootloader. The old fw configuration (u-boot) is not compatible with the new one and will not be supported anymore. So at the end 2 image can be generated: 1) factory image with jboot bootloader openwrt-ramips-rt305x-dwr-512-b-squashfs-factory.bin 2) sysupgrade image with jboot bootloader openwrt-ramips-rt305x-dwr-512-b-squashfs-sysupgrade.bin Signed-off-by: Giuseppe Lippolis <giu.lippolis@gmail.com>
Diffstat (limited to 'target/linux/ramips/image')
-rw-r--r--target/linux/ramips/image/rt305x.mk14
1 files changed, 11 insertions, 3 deletions
diff --git a/target/linux/ramips/image/rt305x.mk b/target/linux/ramips/image/rt305x.mk
index dbf15bc7d7..5a4ca73517 100644
--- a/target/linux/ramips/image/rt305x.mk
+++ b/target/linux/ramips/image/rt305x.mk
@@ -302,10 +302,18 @@ TARGET_DEVICES += dir-620-d1
define Device/dwr-512-b
DTS := DWR-512-B
- IMAGE_SIZE := 7700k
+ IMAGE_SIZE := 7800k
DEVICE_TITLE := D-Link DWR-512 B
- DEVICE_PACKAGES := kmod-usb2 kmod-spi-dev kmod-usb-serial kmod-usb-serial-option \
- kmod-usb-net kmod-usb-net-cdc-ether comgt-ncm
+ DEVICE_PACKAGES := jboot-tools kmod-usb2 kmod-spi-dev kmod-usb-serial \
+ kmod-usb-serial-option kmod-usb-net kmod-usb-net-cdc-ether \
+ comgt-ncm
+ DLINK_ROM_ID := DLK6E2412001
+ DLINK_FAMILY_MEMBER := 0x6E24
+ DLINK_FIRMWARE_SIZE := 0x7E0000
+ KERNEL := $(KERNEL_DTB)
+ IMAGES += factory.bin
+ IMAGE/sysupgrade.bin := mkdlinkfw | pad-rootfs | append-metadata
+ IMAGE/factory.bin := mkdlinkfw | pad-rootfs | mkdlinkfw-factory
endef
TARGET_DEVICES += dwr-512-b