aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2012-03-04 16:09:13 +0000
committerGabor Juhos <juhosg@openwrt.org>2012-03-04 16:09:13 +0000
commit0e486d2fd297d28ddfc34d4adb4eae7050f0d138 (patch)
tree5cc9baa2d7bb54a368db6f1389e9d1526ccac4d8 /target/linux/ramips/image
parent44c8b396f990bb1e762e1f9cef9bca34b78dc9f7 (diff)
downloadupstream-0e486d2fd297d28ddfc34d4adb4eae7050f0d138.tar.gz
upstream-0e486d2fd297d28ddfc34d4adb4eae7050f0d138.tar.bz2
upstream-0e486d2fd297d28ddfc34d4adb4eae7050f0d138.zip
ramips: add support for unbranded XDX-RN502J board
This patch adds support for routers using a PCB marked XDX-RN502J V2.0, such as some unbranded routers like this: http://www.mediafire.com/?8acv87h6snn9fj6 http://www.mediafire.com/?do7xonw7scor4kn http://www.mediafire.com/?1ad49zvx3e7jyix http://www.mediafire.com/?i46cqiq66maa197 http://www.aliexpress.com/product-fm/516397994-Free-Shipping-300M-3G-WAN-Wireless-N-WiFi-USB-AP-Router-2-Antennas-wholesalers.html some reports also state the Aceex 22Y uses the same board. more information can be found in the following openwrt forum post https://forum.openwrt.org/viewtopic.php?id=34878 [juhosg: fix checkpatch warnings, use the GENERIC_4M template] Signed-off-by: bruno schwander <bruno@tinkerbox.org> SVN-Revision: 30809
Diffstat (limited to 'target/linux/ramips/image')
-rw-r--r--target/linux/ramips/image/Makefile5
1 files changed, 5 insertions, 0 deletions
diff --git a/target/linux/ramips/image/Makefile b/target/linux/ramips/image/Makefile
index bb6124c9ab..90bbff95b3 100644
--- a/target/linux/ramips/image/Makefile
+++ b/target/linux/ramips/image/Makefile
@@ -391,6 +391,10 @@ define Image/Build/Profile/WR6202
$(call Image/Build/Template/$(fs_squash)/$(1),GENERIC_8M,wr6202,WR6202,ttyS1,115200,phys)
endef
+define Image/Build/Profile/XDXRN502J
+ $(call Image/Build/Template/$(fs_squash)/$(1),GENERIC_4M,xdxrn502j,XDXRN502J,ttyS1,57600,phys)
+endef
+
ifeq ($(CONFIG_RALINK_RT305X),y)
define Image/Build/Profile/Default
$(call Image/Build/Profile/ALL0256N,$(1))
@@ -417,6 +421,7 @@ define Image/Build/Profile/Default
$(call Image/Build/Profile/WL351,$(1))
$(call Image/Build/Profile/WR5123GN,$(1))
$(call Image/Build/Profile/WR6202,$(1))
+ $(call Image/Build/Profile/XDXRN502J,$(1))
endef
endif