aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image
diff options
context:
space:
mode:
authorAlexey Kosmakov <a.kosmakov@nagtech.ru>2022-05-30 13:46:34 +0500
committerHauke Mehrtens <hauke@hauke-m.de>2022-10-02 20:21:55 +0200
commita664d39c5bb4a77ffc90a6fdfdca3606292b650d (patch)
treeaa737736e7c71bd911b9384f7366b1474ec3c47a /target/linux/ramips/image
parentbf5b1a53d4ff3f1d742f9ece1ab16555280417ec (diff)
downloadupstream-a664d39c5bb4a77ffc90a6fdfdca3606292b650d.tar.gz
upstream-a664d39c5bb4a77ffc90a6fdfdca3606292b650d.tar.bz2
upstream-a664d39c5bb4a77ffc90a6fdfdca3606292b650d.zip
ramips: add support for SNR SNR-CPE-ME2-Lite
SNR SNR-CPE-ME2-Lite is a 2.4/5 GHz band 11ac (Wi-Fi 5) router, based on MT7621A. Specification: - SoC : MediaTek MT7621A - RAM : DDR3 128 MiB - Flash : SPI-NOR 16 MiB - WLAN : 2.4 GHz 2T2R (MediaTek MT7603E) 5 GHz 2T2R (MediaTek MT7613BE) - Ethernet : 10/100/1000 Mbps x5 - Switch : MediaTek MT7530 (SoC) - UART : through-hole on PCB - J4: 3.3V, GND, TX, RX - 57600n8 - Power : 12 VDC, 1.5 A Flash instruction via WEB (firmware 1.10.4 and later) 1. Boot SNR-CPE-ME2-Lite normally with "Router" mode 2. Access to "http://192.168.1.1/" and open "Administration -> Management" page 3. Select the OpenWrt factory image in "Firmware update" section and click "Update" button 4. Wait ~120 seconds to complete flashing Flash instruction via TFTP (all version): 1. Boot SNR-CPE-ME2-Lite to recovery mode (hold the reset button while power on) 2. Send firmware via TFTP client: TFTP Server address: 192.168.1.1 TFTP Client address: 192.168.1.131 3. Wait ~120 seconds to complete flashing Signed-off-by: Alexey Kosmakov <a.kosmakov@nagtech.ru>
Diffstat (limited to 'target/linux/ramips/image')
-rw-r--r--target/linux/ramips/image/mt7621.mk11
1 files changed, 11 insertions, 0 deletions
diff --git a/target/linux/ramips/image/mt7621.mk b/target/linux/ramips/image/mt7621.mk
index 92fc9ec12e..10add92a23 100644
--- a/target/linux/ramips/image/mt7621.mk
+++ b/target/linux/ramips/image/mt7621.mk
@@ -1723,6 +1723,17 @@ define Device/sercomm_na502s
endef
TARGET_DEVICES += sercomm_na502s
+define Device/snr_snr-cpe-me2-lite
+ $(Device/dsa-migration)
+ $(Device/uimage-lzma-loader)
+ IMAGE_SIZE := 16064k
+ DEVICE_VENDOR := SNR
+ DEVICE_MODEL := SNR-CPE-ME2-Lite
+ UIMAGE_NAME := $$(DEVICE_MODEL)
+ DEVICE_PACKAGES := kmod-mt7603 kmod-mt7615e kmod-mt7663-firmware-ap
+endef
+TARGET_DEVICES += snr_snr-cpe-me2-lite
+
define Device/storylink_sap-g3200u3
$(Device/dsa-migration)
IMAGE_SIZE := 7872k