aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image
diff options
context:
space:
mode:
authorMarc Egerton <foxtrot@realloc.me>2020-10-02 18:30:59 +0100
committerPiotr Dymacz <pepe2k@gmail.com>2020-11-18 23:49:34 +0100
commitf276395cda79996d395209700a51bb94a0e25abd (patch)
tree69d04b4873f98a4b66f364869a139033b8bb1186 /target/linux/ramips/image
parenta92d55efcfb2652c7c7261cc1221077b30041f58 (diff)
downloadupstream-f276395cda79996d395209700a51bb94a0e25abd.tar.gz
upstream-f276395cda79996d395209700a51bb94a0e25abd.tar.bz2
upstream-f276395cda79996d395209700a51bb94a0e25abd.zip
ramips: add support for the Hak5 WiFi Pineapple Mark 7
This patch adds support for the WiFi Pineapple Mark 7, a wireless penetration testing tool. Specifications: * SoC: MediaTek MT7628 (580MHz) * RAM: 256MiB (DDR2) * Storage 1: 32MiB NOR (SPI) * Storage 2: 2GB eMMC * Wireless 1: 802.11b/g/n 2.4GHz (Built In) * Wireless 2: 802.11b/g/n 2.4GHz (MT7601) * Wireless 3: 802.11b/g/n 2.4GHz (MT7601) * USB: 1x USB Type-A 2.0 Host Port * Ethernet: 1x USB Type-C AX88772C Ethernet * UART: 57600 8N1 on PCB * Inputs: 1x Reset Button * Outputs: 1x RGB LED * FCCID: 2AA52MK7 Flash Instructions: Original firmware is based on OpenWRT. Use sysupgrade via SSH to flash. Signed-off-by: Marc Egerton <foxtrot@realloc.me> [pepe2k@gmail.com: set only required/used gpio groups to gpio function] Signed-off-by: Piotr Dymacz <pepe2k@gmail.com>
Diffstat (limited to 'target/linux/ramips/image')
-rw-r--r--target/linux/ramips/image/mt76x8.mk9
1 files changed, 9 insertions, 0 deletions
diff --git a/target/linux/ramips/image/mt76x8.mk b/target/linux/ramips/image/mt76x8.mk
index 6327c95bb0..5459288341 100644
--- a/target/linux/ramips/image/mt76x8.mk
+++ b/target/linux/ramips/image/mt76x8.mk
@@ -119,6 +119,15 @@ define Device/glinet_vixmini
endef
TARGET_DEVICES += glinet_vixmini
+define Device/hak5_wifi-pineapple-mk7
+ IMAGE_SIZE := 32448k
+ DEVICE_VENDOR := Hak5
+ DEVICE_MODEL := WiFi Pineapple Mark 7
+ DEVICE_PACKAGES := kmod-usb2 kmod-usb-ohci
+ SUPPORTED_DEVICES += wifi-pineapple-mk7
+endef
+TARGET_DEVICES += hak5_wifi-pineapple-mk7
+
define Device/hilink_hlk-7628n
IMAGE_SIZE := 32448k
DEVICE_VENDOR := HILINK