aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image
diff options
context:
space:
mode:
authorYong-hyu Ban <perillamint@quendi.moe>2019-10-07 05:06:31 +0900
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-01-05 23:38:00 +0100
commit99dd2709b855baa9e68c7c7106743a7c4a91ee0c (patch)
treee1e23398cc3a3ca9598eb705c7df486029f35aa0 /target/linux/ramips/image
parent8fc25d8664841ff1cd0f3082b4c404cab76d6341 (diff)
downloadupstream-99dd2709b855baa9e68c7c7106743a7c4a91ee0c.tar.gz
upstream-99dd2709b855baa9e68c7c7106743a7c4a91ee0c.tar.bz2
upstream-99dd2709b855baa9e68c7c7106743a7c4a91ee0c.zip
ramips: add support for ipTIME A8004T
ipTIME A8004T is a 2.4/5GHz band AC2600 router, based on Mediatek MT7621A. Specifications: - SoC: MT7621A - RAM: DDR3 256M - Flash: SPI NOR 16MB - WiFi: - 2.4GHz: MT7615E - 5GHz: MT7615E - Ethernet: 5x 10/100/1000Mbps - Switch: SoC internal - USB: 1 * USB3.0 port - UART: - J4: 3.3V, TX, RX, GND (3.3V is the square pad) / 57600 8N1 - Other info: - J9: Unknown unpopulated header. Installation via web interface: 1. Flash **initramfs** image through the stock web interface. 2. Boot into OpenWrt and perform sysupgrade with sysupgrade image. Revert to stock firmware: 1. Perform sysupgrade with stock image. Signed-off-by: Yong-hyu Ban <perillamint@quendi.moe> [do not enable xhci node in DTS which is already enabled in DTSI] Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
Diffstat (limited to 'target/linux/ramips/image')
-rw-r--r--target/linux/ramips/image/mt7621.mk10
1 files changed, 10 insertions, 0 deletions
diff --git a/target/linux/ramips/image/mt7621.mk b/target/linux/ramips/image/mt7621.mk
index b33c2c5bc0..2baec6aa2f 100644
--- a/target/linux/ramips/image/mt7621.mk
+++ b/target/linux/ramips/image/mt7621.mk
@@ -382,6 +382,16 @@ define Device/iptime_a6ns-m
endef
TARGET_DEVICES += iptime_a6ns-m
+define Device/iptime_a8004t
+ SOC := mt7621
+ IMAGE_SIZE := 16128k
+ UIMAGE_NAME := a8004t
+ DEVICE_VENDOR := ipTIME
+ DEVICE_MODEL := A8004T
+ DEVICE_PACKAGES := kmod-mt7615e kmod-usb3 wpad-basic
+endef
+TARGET_DEVICES += iptime_a8004t
+
define Device/jcg_jhr-ac876m
SOC := mt7621
IMAGE_SIZE := 16064k