aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image/rt305x.mk
diff options
context:
space:
mode:
authorSergei Burakov <senior.anonymous@ya.ru>2020-05-28 21:24:55 +0300
committerPetr Štetiar <ynezz@true.cz>2020-07-08 22:52:40 +0200
commit4dc9ad4af8c921494d20b303b6772fc6b5af3a69 (patch)
tree13f41b19074efd87c7c7a61f85c6fe0435b9577a /target/linux/ramips/image/rt305x.mk
parent9e6257c26ca29a6040f55c517030e04be95005f2 (diff)
downloadupstream-4dc9ad4af8c921494d20b303b6772fc6b5af3a69.tar.gz
upstream-4dc9ad4af8c921494d20b303b6772fc6b5af3a69.tar.bz2
upstream-4dc9ad4af8c921494d20b303b6772fc6b5af3a69.zip
ramips: add support for ZyXEL Keenetic Lite Rev.B
Device specification: SoC: RT5350 CPU Frequency: 360 MHz Flash Chip: Macronix MX25L6406E (8192 KiB) RAM: Winbond W9825G6JH-6 (32768 KiB) 5x 10/100 Mbps Ethernet (4x LAN, 1x WAN) 1x external antenna UART (J1) header on PCB (57800 8n1) Wireless: SoC-intergated: 2.4GHz 802.11bgn USB: None 8x LED, 2x button Flash instruction: Configure PC with static IP 192.168.99.8/24 and start TFTP server. Rename "openwrt-ramips-rt305x-zyxel_keenetic-lite-b-squashfs-sysupgrade.bin" to "rt305x_firmware.bin" and place it in TFTP server directory. Connect PC with one of LAN ports, press the reset button, power up the router and keep button pressed until power LED start blinking. Router will download file from TFTP server, write it to flash and reboot. Signed-off-by: Sergei Burakov <senior.anonymous@ya.ru>
Diffstat (limited to 'target/linux/ramips/image/rt305x.mk')
-rw-r--r--target/linux/ramips/image/rt305x.mk9
1 files changed, 9 insertions, 0 deletions
diff --git a/target/linux/ramips/image/rt305x.mk b/target/linux/ramips/image/rt305x.mk
index 3171646b8a..b75d9078e5 100644
--- a/target/linux/ramips/image/rt305x.mk
+++ b/target/linux/ramips/image/rt305x.mk
@@ -1193,6 +1193,15 @@ define Device/zyxel_keenetic
endef
TARGET_DEVICES += zyxel_keenetic
+define Device/zyxel_keenetic-lite-b
+ SOC := rt5350
+ IMAGE_SIZE := 7872k
+ DEVICE_VENDOR := ZyXEL
+ DEVICE_MODEL := Keenetic Lite
+ DEVICE_VARIANT := B
+endef
+TARGET_DEVICES += zyxel_keenetic-lite-b
+
define Device/zyxel_keenetic-start
SOC := rt5350
IMAGE_SIZE := 3776k