aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image/mt76x8.mk
diff options
context:
space:
mode:
authorDavid Bauer <mail@david-bauer.net>2020-01-06 00:31:24 +0100
committerDavid Bauer <mail@david-bauer.net>2020-01-29 15:10:54 +0100
commitb30f2281cce6649567e0194d203f06517d173115 (patch)
treedfdff79461874759203fc5de89258fb540e256b5 /target/linux/ramips/image/mt76x8.mk
parentb3e86cbb4f54d92eb4d145c62a7165067c6a7612 (diff)
downloadupstream-b30f2281cce6649567e0194d203f06517d173115.tar.gz
upstream-b30f2281cce6649567e0194d203f06517d173115.tar.bz2
upstream-b30f2281cce6649567e0194d203f06517d173115.zip
ramips: add support for GL.iNet microuter-N300
The GL.iNet microuter-N300 (internally referred as MT300N-v4) is a pocket-size travel router. It is essentially identical to the VIXMINI (internally referred as MT300N-v3) but with double the RAM and SPI-flash. Additionally, set the label-mac for both the VIXMINI as well as the microuter-N300. Hardware -------- SoC: MediaTek MT7628NN RAM: 128M DDR2 FLASH: 16M LED: Power - WLAN BTN: Reset UART: 115200 8N1 TX and RX are labled on the board as pads next to the SoC Installation via web-interface ------------------------------ 1. Visit the web-interface at 192.168.8.1 Note: The ethernet port is by default WAN. So you need to connect to the router via WiFi 2. Navigate to the Update tab on the left side. 3. Select "Local Update" 4. Upload the OpenWrt sysupgrade image. Note: Make sure you select not to preserve the configuration. Installation via U-Boot ----------------------- 1. Hold down the reset button while powering on the device. Wait for the LED to flash 5 times. 2. Assign yourself a static IPv4 in 192.168.1.0/24 3. Upload the OpenWrt sysupgrade image at 192.168.1.1. Signed-off-by: David Bauer <mail@david-bauer.net>
Diffstat (limited to 'target/linux/ramips/image/mt76x8.mk')
-rw-r--r--target/linux/ramips/image/mt76x8.mk8
1 files changed, 8 insertions, 0 deletions
diff --git a/target/linux/ramips/image/mt76x8.mk b/target/linux/ramips/image/mt76x8.mk
index 5ddeec14d5..37cac84229 100644
--- a/target/linux/ramips/image/mt76x8.mk
+++ b/target/linux/ramips/image/mt76x8.mk
@@ -70,6 +70,14 @@ define Device/glinet_gl-mt300n-v2
endef
TARGET_DEVICES += glinet_gl-mt300n-v2
+define Device/glinet_microuter-n300
+ IMAGE_SIZE := 16064k
+ DEVICE_VENDOR := GL.iNet
+ DEVICE_MODEL := microuter-N300
+ SUPPORTED_DEVICES += microuter-n300
+endef
+TARGET_DEVICES += glinet_microuter-n300
+
define Device/glinet_vixmini
IMAGE_SIZE := 7872k
DEVICE_VENDOR := GL.iNet