aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image/mt76x8.mk
diff options
context:
space:
mode:
authorMathias Kresin <dev@kresin.me>2018-11-26 12:34:48 +0100
committerMathias Kresin <dev@kresin.me>2018-11-26 15:54:22 +0100
commit8ec1a66c34d85bdd13754e4171333a763aaf0a00 (patch)
tree2a33da3086bcb5c086af201bb7adec64a2cd92fc /target/linux/ramips/image/mt76x8.mk
parent533f7673ae08a71269cd1f7728f8e8e1983bbd9c (diff)
downloadupstream-8ec1a66c34d85bdd13754e4171333a763aaf0a00.tar.gz
upstream-8ec1a66c34d85bdd13754e4171333a763aaf0a00.tar.bz2
upstream-8ec1a66c34d85bdd13754e4171333a763aaf0a00.zip
ramips: improve Skylab SKW92A support
Use the generic board detection instead of the target specific one as all recent additions are doing. Add the wireless led according the gpio number from the datasheet. Rename the board part of the leds to match the name used for the compatible string. Finally, do not hijack the wps led for boot status indication longer than necessary. Merge userspace config into existing cases. Include the manufacture Name in the dts model string. Signed-off-by: Mathias Kresin <dev@kresin.me>
Diffstat (limited to 'target/linux/ramips/image/mt76x8.mk')
-rw-r--r--target/linux/ramips/image/mt76x8.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/target/linux/ramips/image/mt76x8.mk b/target/linux/ramips/image/mt76x8.mk
index 5f40262e84..3174988f49 100644
--- a/target/linux/ramips/image/mt76x8.mk
+++ b/target/linux/ramips/image/mt76x8.mk
@@ -150,13 +150,13 @@ define Device/pbr-d1
endef
TARGET_DEVICES += pbr-d1
-define Device/skw92a
+define Device/skylab_skw92a
DTS := SKW92A
IMAGE_SIZE := 16064k
DEVICE_TITLE := Skylab SKW92A
DEVICE_PACKAGES := kmod-usb2 kmod-usb-ohci
endef
-TARGET_DEVICES += skw92a
+TARGET_DEVICES += skylab_skw92a
define Device/tplink_tl-wa801nd-v5
$(Device/tplink)