aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image/mt76x8.mk
diff options
context:
space:
mode:
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-08-03 12:02:48 +0200
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-08-03 12:17:08 +0200
commit1deaf695ec02d765c9ae28b1bac264798ca54a05 (patch)
tree535a5ef2cb725c714b96377780441bec9f6e2d5e /target/linux/ramips/image/mt76x8.mk
parent18b7d87a8f76b4cf36e943d9211bd26d79f55ec6 (diff)
downloadupstream-1deaf695ec02d765c9ae28b1bac264798ca54a05.tar.gz
upstream-1deaf695ec02d765c9ae28b1bac264798ca54a05.tar.bz2
upstream-1deaf695ec02d765c9ae28b1bac264798ca54a05.zip
ramips: fix/tidy up 4M tplink-v2-image flash layouts
For the TP-Link 4M devices with tplink-v2-image recipe (mktplinkfw2.c), there are two different flash layouts based on the size of the (u)boot partition: device uboot OEM firmware OpenWrt (incl. config) tl-wr840n-v5 0x20000 0x3c0000 0x3d0000 tl-wr841n-v14 0x10000 0x3d0000 0x3e0000 In both cases, the 0x10000 config partition is used for the firmware partition as well due to the limited space available and since it's recreated by the OEM firmware anyway. However, the TFTP flashing process will only copy data up to the size of the initial (OEM) firmware size. Therefore, while we can use the bigger partition to have additional erase blocks on the device, we have to limit the image sizes to the TFTP limits. So far, only one layout definition has been set up in mktplinkfw2.c for 4M mediatek devices. This adds a second one and assigns them to the devices so the image sizes are correctly restrained. Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
Diffstat (limited to 'target/linux/ramips/image/mt76x8.mk')
-rw-r--r--target/linux/ramips/image/mt76x8.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/target/linux/ramips/image/mt76x8.mk b/target/linux/ramips/image/mt76x8.mk
index 00c8fbe43e..9ec469d32d 100644
--- a/target/linux/ramips/image/mt76x8.mk
+++ b/target/linux/ramips/image/mt76x8.mk
@@ -528,7 +528,7 @@ define Device/tplink_tl-wr841n-v14
IMAGE_SIZE := 3968k
DEVICE_MODEL := TL-WR841N
DEVICE_VARIANT := v14
- TPLINK_FLASHLAYOUT := 4Mmtk
+ TPLINK_FLASHLAYOUT := 4MLmtk
TPLINK_HWID := 0x08410014
TPLINK_HWREVADD := 0x14
IMAGES := sysupgrade.bin tftp-recovery.bin