aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image/mt76x8.mk
diff options
context:
space:
mode:
authorDeng Qingfang <dengqf6@mail2.sysu.edu.cn>2018-08-10 01:22:46 +0800
committerMathias Kresin <dev@kresin.me>2018-08-14 10:21:32 +0200
commitd20f4fc628e9e3c1e1d4063a0798e4097ffb3c4a (patch)
tree006e341d74b48dd3027c4352aaafb171536165b9 /target/linux/ramips/image/mt76x8.mk
parent1213504750bf27b46fd958d236fcf56f33d2d8cd (diff)
downloadupstream-old-master.tar.gz
upstream-old-master.tar.bz2
upstream-old-master.zip
ramips: add support for HiWiFi HC5861Bold-master
HiWiFi "Gee Enjoy1200" HC5861B is a dual-band router based on MediaTek MT7628AN https://www.hiwifi.com/enjoy-view Specifications: - MediaTek MT7628AN 580MHz - 128 MB DDR2 RAM - 16 MB SPI Flash - 2.4G MT7628AN 802.11bgn 2T2R 300Mbps - 5G MT7612EN 802.11ac 2T2R 867Mbps - 5x 10/100 Mbps Ethernet Flash instruction: 1. Get SSH access to the router 2. SSH to router with `ssh -p 1022 root@192.168.199.1`, The SSH password is the same as the webconfig one 3. Upload OpenWrt sysupgrade firmware into the router's `/tmp` folder with SCP 4. Run `mtd write /tmp/<filename> firmware` 5. reboot Everything is working Signed-off-by: Deng Qingfang <dengqf6@mail2.sysu.edu.cn>
Diffstat (limited to 'target/linux/ramips/image/mt76x8.mk')
-rw-r--r--target/linux/ramips/image/mt76x8.mk7
1 files changed, 7 insertions, 0 deletions
diff --git a/target/linux/ramips/image/mt76x8.mk b/target/linux/ramips/image/mt76x8.mk
index eddbbea3c2..0c657d5a0f 100644
--- a/target/linux/ramips/image/mt76x8.mk
+++ b/target/linux/ramips/image/mt76x8.mk
@@ -69,6 +69,13 @@ define Device/hc5661a
endef
TARGET_DEVICES += hc5661a
+define Device/hiwifi_hc5861b
+ DTS := HC5861B
+ IMAGE_SIZE := 15808k
+ DEVICE_TITLE := HiWiFi HC5861B
+endef
+TARGET_DEVICES += hiwifi_hc5861b
+
define Device/LinkIt7688
DTS := LINKIT7688
IMAGE_SIZE := $(ralink_default_fw_size_32M)