aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image/mt7621.mk
diff options
context:
space:
mode:
authorINAGAKI Hiroshi <musashino.open@gmail.com>2020-12-11 23:14:58 +0900
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2021-01-29 15:32:07 +0100
commiteb11cd9ea3822b34df6260b1dd40fc4f0866b804 (patch)
treee018ff967cbaafd4aeb81c0d8d30c932f173b1b5 /target/linux/ramips/image/mt7621.mk
parent0071c7cd8246197ae27d8a0c4b5bdf7976dbe362 (diff)
downloadupstream-eb11cd9ea3822b34df6260b1dd40fc4f0866b804.tar.gz
upstream-eb11cd9ea3822b34df6260b1dd40fc4f0866b804.tar.bz2
upstream-eb11cd9ea3822b34df6260b1dd40fc4f0866b804.zip
ramips: add support for ELECOM WRC-2533GHBK-I
ELECOM WRC-2533GHBK-I is a 2.4/5 GHz band 11ac (Wi-Fi 5) router, based on MT7621A. Specification: - SoC : MediaTek MT7621A - RAM : DDR3 128 MiB - Flash : SPI-NOR 16 MiB - WLAN : 2.4/5 GHz 4T4R (2x MediaTek MT7615) - Ethernet : 10/100/1000 Mbps x5 - Switch : MediaTek MT7530 (SoC) - LED/keys : 4x/3x (2x buttons, 1x slide-switch) - UART : through-hole on PCB - J4: 3.3V, RX, GND, TX from SoC side - 57600n8 - Power : 12VDC, 1.5A Flash instruction using factory image: 1. Boot WRC-2533GHBK-I normally 2. Access to "http://192.168.2.1/" and open firmware update page ("ファームウェア更新") 3. Select the OpenWrt factory image and click apply ("適用") button 4. Wait ~150 seconds to complete flashing MAC addresses: LAN : BC:5C:4C:xx:xx:89 (Config, ethaddr (text)) WAN : BC:5C:4C:xx:xx:88 (Config, wanaddr (text)) 2.4GHz : BC:5C:4C:xx:xx:8A (Factory, 0x4 (hex)) 5GHz : BC:5C:4C:xx:xx:8B (Factory, 0x8004 (hex)) Signed-off-by: INAGAKI Hiroshi <musashino.open@gmail.com> Reviewed-by: Sungbo Eo <mans0n@gorani.run>
Diffstat (limited to 'target/linux/ramips/image/mt7621.mk')
-rw-r--r--target/linux/ramips/image/mt7621.mk14
1 files changed, 14 insertions, 0 deletions
diff --git a/target/linux/ramips/image/mt7621.mk b/target/linux/ramips/image/mt7621.mk
index ec34e61268..ce3a352337 100644
--- a/target/linux/ramips/image/mt7621.mk
+++ b/target/linux/ramips/image/mt7621.mk
@@ -466,6 +466,20 @@ define Device/elecom_wrc-1900gst
endef
TARGET_DEVICES += elecom_wrc-1900gst
+define Device/elecom_wrc-2533ghbk-i
+ $(Device/dsa-migration)
+ $(Device/uimage-lzma-loader)
+ DEVICE_VENDOR := ELECOM
+ DEVICE_MODEL := WRC-2533GHBK-I
+ IMAGE_SIZE := 9856k
+ IMAGES += factory.bin
+ IMAGE/factory.bin := $$(sysupgrade_bin) | check-size | \
+ elx-header 0107002d 8844A2D168B45A2D | \
+ elecom-product-header WRC-2533GHBK-I
+ DEVICE_PACKAGES := kmod-mt7615e kmod-mt7615-firmware
+endef
+TARGET_DEVICES += elecom_wrc-2533ghbk-i
+
define Device/elecom_wrc-2533gst
$(Device/elecom_wrc-gs)
IMAGE_SIZE := 11264k