aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image/mt7621.mk
diff options
context:
space:
mode:
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-04-07 10:47:18 +0200
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-04-12 13:25:42 +0200
commite8931b309f82a44b55e64af3668186cdf7bcde15 (patch)
tree756df8b4b54a73b2f4acd69ec48df19fe29b5410 /target/linux/ramips/image/mt7621.mk
parentbebc9809d15b0ddc018d379f5caa3a11c9a06786 (diff)
downloadupstream-e8931b309f82a44b55e64af3668186cdf7bcde15.tar.gz
upstream-e8931b309f82a44b55e64af3668186cdf7bcde15.tar.bz2
upstream-e8931b309f82a44b55e64af3668186cdf7bcde15.zip
ramips: mt7621: tidy up names for Ubiquiti devices
The "proper" vendor prefix for Ubiquiti is "ubnt", this is used in all targets except ramips and also recommended by the kernel. This patch adjusts the various board/image/device name variables accordingly. Since we touch it anyway, this also adds the space in "EdgeRouter X" as a hyphen to those variables to really make them consistent with the model name. While at it, create a real shared definition for the devices in image/mt7621.mk instead of deriving one device from another. Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
Diffstat (limited to 'target/linux/ramips/image/mt7621.mk')
-rw-r--r--target/linux/ramips/image/mt7621.mk23
1 files changed, 13 insertions, 10 deletions
diff --git a/target/linux/ramips/image/mt7621.mk b/target/linux/ramips/image/mt7621.mk
index 6b2e68b03b..806286b0bb 100644
--- a/target/linux/ramips/image/mt7621.mk
+++ b/target/linux/ramips/image/mt7621.mk
@@ -794,27 +794,30 @@ define Device/tplink_re650-v1
endef
TARGET_DEVICES += tplink_re650-v1
-define Device/ubiquiti_edgerouterx
+define Device/ubnt_edgerouter_common
+ DEVICE_VENDOR := Ubiquiti
IMAGE_SIZE := 256768k
FILESYSTEMS := squashfs
KERNEL_SIZE := 3145728
KERNEL_INITRAMFS := $$(KERNEL) | \
ubnt-erx-factory-image $(KDIR)/tmp/$$(KERNEL_INITRAMFS_PREFIX)-factory.tar
IMAGE/sysupgrade.bin := sysupgrade-tar | append-metadata
- DEVICE_VENDOR := Ubiquiti
+endef
+
+define Device/ubnt_edgerouter-x
+ $(Device/ubnt_edgerouter_common)
DEVICE_MODEL := EdgeRouter X
- SUPPORTED_DEVICES += ubnt-erx
+ SUPPORTED_DEVICES += ubnt-erx ubiquiti,edgerouterx
endef
-TARGET_DEVICES += ubiquiti_edgerouterx
+TARGET_DEVICES += ubnt_edgerouter-x
-define Device/ubiquiti_edgerouterx-sfp
- $(Device/ubiquiti_edgerouterx)
- DEVICE_VENDOR := Ubiquiti
- DEVICE_MODEL := EdgeRouter X-SFP
+define Device/ubnt_edgerouter-x-sfp
+ $(Device/ubnt_edgerouter_common)
+ DEVICE_MODEL := EdgeRouter X SFP
DEVICE_PACKAGES += kmod-i2c-algo-pca kmod-gpio-pca953x
- SUPPORTED_DEVICES += ubnt-erx-sfp
+ SUPPORTED_DEVICES += ubnt-erx-sfp ubiquiti,edgerouterx-sfp
endef
-TARGET_DEVICES += ubiquiti_edgerouterx-sfp
+TARGET_DEVICES += ubnt_edgerouter-x-sfp
define Device/ubnt_unifi-nanohd
DEVICE_VENDOR := Ubiquiti