aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image/mt7621.mk
diff options
context:
space:
mode:
authorINAGAKI Hiroshi <musashino.open@gmail.com>2019-03-23 22:45:42 +0900
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-04-07 17:04:18 +0200
commite8787291b351a98a522ecc255a1da78394558588 (patch)
tree794f0b22005c100888e445e92e67a2947725b792 /target/linux/ramips/image/mt7621.mk
parentc459a6bf482f5afc4746a4a108a143e9194cd59d (diff)
downloadupstream-e8787291b351a98a522ecc255a1da78394558588.tar.gz
upstream-e8787291b351a98a522ecc255a1da78394558588.tar.bz2
upstream-e8787291b351a98a522ecc255a1da78394558588.zip
ramips: add support for Buffalo WSR-2533DHPL
Buffalo WSR-2533DHPL is a 2.4/5 GHz band 11ac router, based on MediaTek MT7621A. Specification: - SoC : MediaTek MT7621A - RAM : DDR3 128 MiB - Flash : SPI-NOR 16 MiB - WLAN : 2.4/5 GHz 4T4R (2x MediaTek MT7615N) - Ethernet : 10/100/1000 Mbps - Switch : MediaTek MT7530 (SoC) - LED/keys : 8x/6x (3x buttons, 2x slide-switches) - UART : through-hole on PCB - J4: 3.3V, GND, TX, RX from triangle-mark - 57600n8 - Power : 12VDC 1.5A Flash instruction using initramfs image: 1. prepare the TFTP server with the initramfs image renamed to "linux.trx-recovery" and IP address "192.168.11.2" 2. press the "AOSS" button while powering on the WSR-2533DHPL 3. after 10 seconds, release the "AOSS" button, WSR-2533DHPL downloads the initramfs image and boot with it automatically 4. on the initramfs image, download the sysupgrade image to the device and perform sysupgrade with it 5. wait ~120 seconds to complete flashing Switch position overview: - slide-switch1 (2x positions) - "AUTO" - "MANUAL" (not connected to gpio) - slide-switch2 (3x positions) - "ROUTER" - "AP" (not connected to gpio) - "WB" Signed-off-by: INAGAKI Hiroshi <musashino.open@gmail.com> [add note on switches, fix group->groups for state_default] Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
Diffstat (limited to 'target/linux/ramips/image/mt7621.mk')
-rw-r--r--target/linux/ramips/image/mt7621.mk9
1 files changed, 9 insertions, 0 deletions
diff --git a/target/linux/ramips/image/mt7621.mk b/target/linux/ramips/image/mt7621.mk
index cdae42f3e4..30552ebee1 100644
--- a/target/linux/ramips/image/mt7621.mk
+++ b/target/linux/ramips/image/mt7621.mk
@@ -196,6 +196,15 @@ define Device/buffalo_wsr-1166dhp
endef
TARGET_DEVICES += buffalo_wsr-1166dhp
+define Device/buffalo_wsr-2533dhpl
+ IMAGE_SIZE := 7936k
+ DEVICE_VENDOR := Buffalo
+ DEVICE_MODEL := WSR-2533DHPL
+ IMAGE/sysupgrade.bin := trx | pad-rootfs | append-metadata
+ DEVICE_PACKAGES := kmod-mt7615e wpad-basic
+endef
+TARGET_DEVICES += buffalo_wsr-2533dhpl
+
define Device/buffalo_wsr-600dhp
IMAGE_SIZE := 16064k
DEVICE_VENDOR := Buffalo