aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image/mt7621.mk
diff options
context:
space:
mode:
authorNOGUCHI Hiroshi <drvlabo@gmail.com>2018-08-19 08:05:15 +0900
committerMathias Kresin <dev@kresin.me>2018-08-23 22:42:09 +0200
commitad10e71becfb36d36c81c5b0e898c4ea7912d778 (patch)
tree0be82e00416ca75fddef7f0e2abb1fb5c3f8ac23 /target/linux/ramips/image/mt7621.mk
parentb8996ea08a6883c15959eae041521ac8e267bb5d (diff)
downloadupstream-ad10e71becfb36d36c81c5b0e898c4ea7912d778.tar.gz
upstream-ad10e71becfb36d36c81c5b0e898c4ea7912d778.tar.bz2
upstream-ad10e71becfb36d36c81c5b0e898c4ea7912d778.zip
ramips: add support for ELECOM WRC-1900GST
ELECOM WRC-1900GST is a wireless router, based on Mediatek MT7621A. This is almost same as WRC-2533GST except wireless specs. Specifications: - SoC : MT7621A (four logical CPU cores) - RAM : 128MiB - ROM : 16MiB of SPI NOR-FLASH - wireless : 5GHz : 3T3R up to 1300Mbps/11ac with MT7615 2.4GHz : 3T3R up to 600Mbps/11n with MT7615 - Ethernet : 5 ports, all ports is capable of 1000base-T - Ether switch : MT7530 (MT7621A built-in) - LEDs : 4 LEDs - buttons : 2 buttons and 1 slide-switch - UART : header is on PCB, 57600bps Flash instruction using factory image: 1. Connect the computer to the LAN port of WRC-1900GST 2. Connect power cable to WRC-1900GST and turn on it 3. Access to "https://192.168.2.1/" and open firmware update page ("ファームウェア更新") 4. Select the OpenWrt factory image and click apply ("適用") button 5. Wait ~150 seconds to complete flashing Signed-off-by: NOGUCHI Hiroshi <drvlabo@gmail.com>
Diffstat (limited to 'target/linux/ramips/image/mt7621.mk')
-rw-r--r--target/linux/ramips/image/mt7621.mk10
1 files changed, 10 insertions, 0 deletions
diff --git a/target/linux/ramips/image/mt7621.mk b/target/linux/ramips/image/mt7621.mk
index b427ff4f25..4195c22691 100644
--- a/target/linux/ramips/image/mt7621.mk
+++ b/target/linux/ramips/image/mt7621.mk
@@ -127,6 +127,16 @@ define Device/elecom_wrc-2533gst
endef
TARGET_DEVICES += elecom_wrc-2533gst
+define Device/elecom_wrc-1900gst
+ DTS := WRC-1900GST
+ IMAGE_SIZE := 11264k
+ DEVICE_TITLE := ELECOM WRC-1900GST
+ IMAGES += factory.bin
+ IMAGE/factory.bin := $$(sysupgrade_bin) | check-size $$$$(IMAGE_SIZE) |\
+ elecom-gst-factory WRC-1900GST 0.00
+endef
+TARGET_DEVICES += elecom_wrc-1900gst
+
define Device/ew1200
DTS := EW1200
IMAGE_SIZE := $(ralink_default_fw_size_16M)