aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image/mt7621.mk
diff options
context:
space:
mode:
authorSander Vanheule <sander@svanheule.net>2020-11-04 10:21:14 +0100
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-11-25 15:51:22 +0100
commit9f574b1b875cd6e5dbb521b841c9196995b46bfc (patch)
tree76b507a8e629689aa7470a3da25bc492d3c9a59a /target/linux/ramips/image/mt7621.mk
parent8416d0626f57ff3303a44a7b9e29f97c3e380e63 (diff)
downloadupstream-9f574b1b875cd6e5dbb521b841c9196995b46bfc.tar.gz
upstream-9f574b1b875cd6e5dbb521b841c9196995b46bfc.tar.bz2
upstream-9f574b1b875cd6e5dbb521b841c9196995b46bfc.zip
ramips: mt7621: drop custom uImage function
Use the mkimage argument overrides provided by uImage to implement the customisations required for the initramfs, instead of the near-identical custom function. Signed-off-by: Sander Vanheule <sander@svanheule.net>
Diffstat (limited to 'target/linux/ramips/image/mt7621.mk')
-rw-r--r--target/linux/ramips/image/mt7621.mk31
1 files changed, 10 insertions, 21 deletions
diff --git a/target/linux/ramips/image/mt7621.mk b/target/linux/ramips/image/mt7621.mk
index bac3185507..d3b96f5f4b 100644
--- a/target/linux/ramips/image/mt7621.mk
+++ b/target/linux/ramips/image/mt7621.mk
@@ -7,21 +7,7 @@ include ./common-tp-link.mk
DEFAULT_SOC := mt7621
KERNEL_DTB += -d21
-DEVICE_VARS += UIMAGE_MAGIC ELECOM_HWNAME LINKSYS_HWNAME
-
-# The OEM webinterface expects an kernel with initramfs which has the uImage
-# header field ih_name.
-# We don't want to set the header name field for the kernel include in the
-# sysupgrade image as well, as this image shouldn't be accepted by the OEM
-# webinterface. It will soft-brick the board.
-define Build/custom-initramfs-uimage
- mkimage -A $(LINUX_KARCH) \
- -O linux -T kernel \
- -C lzma -a $(KERNEL_LOADADDR) $(if $(UIMAGE_MAGIC),-M $(UIMAGE_MAGIC),) \
- -e $(if $(KERNEL_ENTRY),$(KERNEL_ENTRY),$(KERNEL_LOADADDR)) \
- -n '$(1)' -d $@ $@.new
- mv $@.new $@
-endef
+DEVICE_VARS += ELECOM_HWNAME LINKSYS_HWNAME
define Build/elecom-wrc-gs-factory
$(eval product=$(word 1,$(1)))
@@ -538,32 +524,35 @@ define Device/iodata_nand
IMAGE/sysupgrade.bin := sysupgrade-tar | append-metadata
endef
+# The OEM webinterface expects an kernel with initramfs which has the uImage
+# header field ih_name.
+# We don't want to set the header name field for the kernel include in the
+# sysupgrade image as well, as this image shouldn't be accepted by the OEM
+# webinterface. It will soft-brick the board.
+
define Device/iodata_wn-ax1167gr2
$(Device/iodata_nand)
- UIMAGE_MAGIC := 0x434f4d42
DEVICE_MODEL := WN-AX1167GR2
KERNEL_INITRAMFS := $(KERNEL_DTB) | loader-kernel | lzma | \
- custom-initramfs-uimage 3.10(XBC.1)b10 | iodata-mstc-header
+ uImage lzma -M 0x434f4d42 -n '3.10(XBC.1)b10' | iodata-mstc-header
DEVICE_PACKAGES := kmod-mt7615e kmod-mt7615-firmware
endef
TARGET_DEVICES += iodata_wn-ax1167gr2
define Device/iodata_wn-ax2033gr
$(Device/iodata_nand)
- UIMAGE_MAGIC := 0x434f4d42
DEVICE_MODEL := WN-AX2033GR
KERNEL_INITRAMFS := $(KERNEL_DTB) | loader-kernel | lzma | \
- custom-initramfs-uimage 3.10(VST.1)C10 | iodata-mstc-header
+ uImage lzma -M 0x434f4d42 -n '3.10(VST.1)C10' | iodata-mstc-header
DEVICE_PACKAGES := kmod-mt7603 kmod-mt7615e kmod-mt7615-firmware
endef
TARGET_DEVICES += iodata_wn-ax2033gr
define Device/iodata_wn-dx1167r
$(Device/iodata_nand)
- UIMAGE_MAGIC := 0x434f4d43
DEVICE_MODEL := WN-DX1167R
KERNEL_INITRAMFS := $(KERNEL_DTB) | loader-kernel | lzma | \
- custom-initramfs-uimage 3.10(XIK.1)b10 | iodata-mstc-header
+ uImage lzma -M 0x434f4d43 -n '3.10(XIK.1)b10' | iodata-mstc-header
DEVICE_PACKAGES := kmod-mt7615e kmod-mt7615-firmware
endef
TARGET_DEVICES += iodata_wn-dx1167r