aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image/mt7621.mk
diff options
context:
space:
mode:
authorFrancois Goudal <francois@goudal.net>2017-02-27 21:59:50 +0100
committerMathias Kresin <dev@kresin.me>2017-03-01 22:29:50 +0100
commit9b35815f0f0e10125d144c82595bbccbc83d6812 (patch)
treed020d431072ff7bc375e770f759e3aa37cbc0d5b /target/linux/ramips/image/mt7621.mk
parent23bf153eadc9a1f0fa761155742f2e7107159a0c (diff)
downloadupstream-9b35815f0f0e10125d144c82595bbccbc83d6812.tar.gz
upstream-9b35815f0f0e10125d144c82595bbccbc83d6812.tar.bz2
upstream-9b35815f0f0e10125d144c82595bbccbc83d6812.zip
ramips: add support for Afoundry EW-1200
This device features both a 2.4 and 5Ghz radio, and supports 802.11a/b/g/n/ac modes. It has 5 Gb-Ethernet ports and a USB 3.0 host port. It is powered by the Mediatek MT7621 SoC, and the MT7602E and MT7612E wifi chipsets, together with 128MB of RAM and 16 MB of SPI Flash. The stock firmware is in fact based on some openwrt barrier breaker, with a mediatek SDK kernel, and an afoundry custom made web interface (not LuCI based). Firmware update page on the stock web interface can not accept sysupgrade images, it bricks the device. At this point, the only working solution I found was to connect to the serial console port (available on J4 header) and to use opkg to install dropbear. Then scp the sysupgrade file in the device's /tmp and run sysupgrade from console without preserving configuration files. Signed-off-by: Francois Goudal <francois@goudal.net>
Diffstat (limited to 'target/linux/ramips/image/mt7621.mk')
-rw-r--r--target/linux/ramips/image/mt7621.mk8
1 files changed, 8 insertions, 0 deletions
diff --git a/target/linux/ramips/image/mt7621.mk b/target/linux/ramips/image/mt7621.mk
index d40c185084..6704f84dc5 100644
--- a/target/linux/ramips/image/mt7621.mk
+++ b/target/linux/ramips/image/mt7621.mk
@@ -63,6 +63,14 @@ define Device/dir-860l-b1
endef
TARGET_DEVICES += dir-860l-b1
+define Device/ew1200
+ DTS := EW1200
+ IMAGE_SIZE := $(ralink_default_fw_size_16M)
+ DEVICE_TITLE := AFOUNDRY EW1200
+ DEVICE_PACKAGES := kmod-usb3 kmod-usb-ledtrig-usbport kmod-ata-core kmod-ata-ahci
+endef
+TARGET_DEVICES += ew1200
+
define Device/firewrt
DTS := FIREWRT
IMAGE_SIZE := $(ralink_default_fw_size_16M)