aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image/mt7621.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2017-11-07 13:17:06 +0100
committerFelix Fietkau <nbd@nbd.name>2017-11-16 12:52:55 +0100
commit9996480b0ee80456af0b9fc3d44580393b09c84b (patch)
tree63c538fc38cde49692311d49ebfa304a4bdaa2e3 /target/linux/ramips/image/mt7621.mk
parent3eb839b5795e6f8d6461f94dbc4217c3641e7f19 (diff)
downloadupstream-9996480b0ee80456af0b9fc3d44580393b09c84b.tar.gz
upstream-9996480b0ee80456af0b9fc3d44580393b09c84b.tar.bz2
upstream-9996480b0ee80456af0b9fc3d44580393b09c84b.zip
ramips: add support for ZBT WE3526
This is a variant of the ZBT WG3526 with a few minor modifications. The wifi chips are swapped, and there is no GPIO controllable status LED. There is also no SATA port. Specifications: - MT7621AT (880 MHz) - 512 MB RAM - 16 MB Flash (SPI NOR) - 5x 1Gbps Ethernet (built-in switch) - MT7612E 802.11ac 5 GHz WLAN - MT7603E 802.11n 2.4 GHz WLAN Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'target/linux/ramips/image/mt7621.mk')
-rw-r--r--target/linux/ramips/image/mt7621.mk11
1 files changed, 11 insertions, 0 deletions
diff --git a/target/linux/ramips/image/mt7621.mk b/target/linux/ramips/image/mt7621.mk
index 1dc5b1df3d..82d0eeae62 100644
--- a/target/linux/ramips/image/mt7621.mk
+++ b/target/linux/ramips/image/mt7621.mk
@@ -329,6 +329,17 @@ define Device/zbt-we1326
endef
TARGET_DEVICES += zbt-we1326
+define Device/zbt-we3526
+ DTS := ZBT-WE3526
+ IMAGE_SIZE := $(ralink_default_fw_size_16M)
+ SUPPORTED_DEVICES += zbt-we3526
+ DEVICE_TITLE := ZBT WE3526
+ DEVICE_PACKAGES := \
+ kmod-sdhci-mt7620 kmod-mt7603 kmod-mt76x2 \
+ kmod-usb3 kmod-usb-ledtrig-usbport wpad-mini
+endef
+TARGET_DEVICES += zbt-we3526
+
define Device/zbt-wg2626
DTS := ZBT-WG2626
IMAGE_SIZE := $(ralink_default_fw_size_16M)