aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image/mt7621.mk
diff options
context:
space:
mode:
authorPavel Chervontsev <cherpash@gmail.com>2020-11-02 14:50:01 +0300
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-11-28 20:51:50 +0100
commit6d98c098e48414b0da8aa6c25aa9044a201c1ba6 (patch)
tree623bb46381a467a2caea5d1d31e1c879234f061c /target/linux/ramips/image/mt7621.mk
parent61e381d3228ab49635319bbbc36e2d49611e0860 (diff)
downloadupstream-6d98c098e48414b0da8aa6c25aa9044a201c1ba6.tar.gz
upstream-6d98c098e48414b0da8aa6c25aa9044a201c1ba6.tar.bz2
upstream-6d98c098e48414b0da8aa6c25aa9044a201c1ba6.zip
ramips: add support for ASUS RT-N56U B1
Specifications: SoC: MediaTek MT7621ST (880 MHz) FLASH: 16 MiB (Macronix MX25L12835FM2I-10G) RAM: 128 MiB (Nanya NT5CB64M16FP-DH) WiFi: MediaTek MT7603EN bgn 2x2:2 WiFi: MediaTek MT7612EN an 2x2:2 BTN: Reset, WPS LED: - Power - WiFi 2.4 GHz - WiFi 5 GHz - WAN - LAN {1-4} - USB {1-2} UART: UART is present as pin hole next to the aluminium capacitor. 3V3 - RX - GND - TX / 115200-8N1 3V3 is the nearest on the aluminium capacitor and nut hole (pin1). USB: 2 ports POWER: 12VDC, 1.5A (Barrel 5.5x2.1) Installation: Via TFTP: Set your computers IP-Address to 192.168.1.75 Power up the Router with the Reset button pressed. Release the Reset button after 5 seconds. Upload OpenWRT sysupgrade image via TFTP: tftp -4 -v -m binary 192.168.1.1 -c put IMAGE MAC addresses: 0x4 *:98 2g/wan, label 0x22 *:9c 0x28 *:98 0x8004 *:9c 5g/lan Though addresses are written to 0x22 and 0x28, it appears that the vendor firmware actually only uses 0x4 and 0x8004. Thus, we do the same here. Signed-off-by: Pavel Chervontsev <cherpash@gmail.com> [add MAC address overview, add label-mac-device, fix IMAGE_SIZE] Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
Diffstat (limited to 'target/linux/ramips/image/mt7621.mk')
-rw-r--r--target/linux/ramips/image/mt7621.mk11
1 files changed, 11 insertions, 0 deletions
diff --git a/target/linux/ramips/image/mt7621.mk b/target/linux/ramips/image/mt7621.mk
index ce9a3ae3d2..7b8a73c1bd 100644
--- a/target/linux/ramips/image/mt7621.mk
+++ b/target/linux/ramips/image/mt7621.mk
@@ -188,6 +188,17 @@ define Device/asus_rt-ac85p
endef
TARGET_DEVICES += asus_rt-ac85p
+define Device/asus_rt-n56u-b1
+ $(Device/dsa-migration)
+ DEVICE_VENDOR := ASUS
+ DEVICE_MODEL := RT-N56U
+ DEVICE_VARIANT := B1
+ IMAGE_SIZE := 16064k
+ DEVICE_PACKAGES := kmod-mt7603 kmod-mt76x2 kmod-usb3 \
+ kmod-usb-ledtrig-usbport
+endef
+TARGET_DEVICES += asus_rt-n56u-b1
+
define Device/buffalo_wsr-1166dhp
$(Device/dsa-migration)
$(Device/uimage-lzma-loader)