aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image/mt7621.mk
diff options
context:
space:
mode:
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-12-08 15:05:47 +0100
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-12-08 17:18:57 +0100
commit6d4382711a65b5606cc9b815e6590b0e36ebf5b5 (patch)
tree36e052b6028e469ad0659f73e80b521b9ed672b1 /target/linux/ramips/image/mt7621.mk
parent89e6cc5c76e675e94c070b920dbe1ff58cfd4436 (diff)
downloadupstream-6d4382711a65b5606cc9b815e6590b0e36ebf5b5.tar.gz
upstream-6d4382711a65b5606cc9b815e6590b0e36ebf5b5.tar.bz2
upstream-6d4382711a65b5606cc9b815e6590b0e36ebf5b5.zip
ramips: use full names for Xiaomi Mi Router devices
This aligns the device/image names of the older Xiaomi Mi Router devices with their "friendly" model and DEVICE_MODEL properties. This also reintroduces consistency with the newer devices already following that scheme. Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
Diffstat (limited to 'target/linux/ramips/image/mt7621.mk')
-rw-r--r--target/linux/ramips/image/mt7621.mk29
1 files changed, 15 insertions, 14 deletions
diff --git a/target/linux/ramips/image/mt7621.mk b/target/linux/ramips/image/mt7621.mk
index 7b8a73c1bd..fad18552c9 100644
--- a/target/linux/ramips/image/mt7621.mk
+++ b/target/linux/ramips/image/mt7621.mk
@@ -1191,13 +1191,7 @@ define Device/xiaomi-ac2100
uboot-envtools
endef
-define Device/xiaomi_mi-router-ac2100
- $(Device/xiaomi-ac2100)
- DEVICE_MODEL := Mi Router AC2100
-endef
-TARGET_DEVICES += xiaomi_mi-router-ac2100
-
-define Device/xiaomi_mir3g
+define Device/xiaomi_mi-router-3g
$(Device/dsa-migration)
$(Device/uimage-lzma-loader)
BLOCKSIZE := 128k
@@ -1211,14 +1205,13 @@ define Device/xiaomi_mir3g
IMAGE/sysupgrade.bin := sysupgrade-tar | append-metadata
DEVICE_VENDOR := Xiaomi
DEVICE_MODEL := Mi Router 3G
- SUPPORTED_DEVICES += R3G
- SUPPORTED_DEVICES += mir3g
DEVICE_PACKAGES := kmod-mt7603 kmod-mt76x2 kmod-usb3 \
kmod-usb-ledtrig-usbport uboot-envtools
+ SUPPORTED_DEVICES += R3G mir3g xiaomi,mir3g
endef
-TARGET_DEVICES += xiaomi_mir3g
+TARGET_DEVICES += xiaomi_mi-router-3g
-define Device/xiaomi_mir3g-v2
+define Device/xiaomi_mi-router-3g-v2
$(Device/dsa-migration)
$(Device/uimage-lzma-loader)
IMAGE_SIZE := 14848k
@@ -1226,10 +1219,11 @@ define Device/xiaomi_mir3g-v2
DEVICE_MODEL := Mi Router 3G
DEVICE_VARIANT := v2
DEVICE_PACKAGES := kmod-mt7603 kmod-mt76x2
+ SUPPORTED_DEVICES += xiaomi,mir3g-v2
endef
-TARGET_DEVICES += xiaomi_mir3g-v2
+TARGET_DEVICES += xiaomi_mi-router-3g-v2
-define Device/xiaomi_mir3p
+define Device/xiaomi_mi-router-3-pro
$(Device/dsa-migration)
$(Device/uimage-lzma-loader)
BLOCKSIZE := 128k
@@ -1245,8 +1239,9 @@ define Device/xiaomi_mir3p
check-size
DEVICE_PACKAGES := kmod-mt7615e kmod-mt7615-firmware kmod-usb3 \
kmod-usb-ledtrig-usbport uboot-envtools
+ SUPPORTED_DEVICES += xiaomi,mir3p
endef
-TARGET_DEVICES += xiaomi_mir3p
+TARGET_DEVICES += xiaomi_mi-router-3-pro
define Device/xiaomi_mi-router-4a-gigabit
$(Device/dsa-migration)
@@ -1259,6 +1254,12 @@ define Device/xiaomi_mi-router-4a-gigabit
endef
TARGET_DEVICES += xiaomi_mi-router-4a-gigabit
+define Device/xiaomi_mi-router-ac2100
+ $(Device/xiaomi-ac2100)
+ DEVICE_MODEL := Mi Router AC2100
+endef
+TARGET_DEVICES += xiaomi_mi-router-ac2100
+
define Device/xiaomi_redmi-router-ac2100
$(Device/xiaomi-ac2100)
DEVICE_MODEL := Redmi Router AC2100