aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image/mt7621.mk
diff options
context:
space:
mode:
authorJ. Scott Heppler <shep971@centurylink.net>2020-09-22 19:30:45 -0700
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-09-23 12:17:32 +0200
commit620f9c773413a0deaeda2bdc22d5e9cb89b9317f (patch)
tree6f25bf531d8d71e3aec1bbdfcd67991118355274 /target/linux/ramips/image/mt7621.mk
parent127ca3c631ea3478d5c9909066b42c117aa72ce0 (diff)
downloadupstream-620f9c773413a0deaeda2bdc22d5e9cb89b9317f.tar.gz
upstream-620f9c773413a0deaeda2bdc22d5e9cb89b9317f.tar.bz2
upstream-620f9c773413a0deaeda2bdc22d5e9cb89b9317f.zip
ramips: add support for Linksys EA7300 v2
This submission relied heavily on the work of Santiago Rodriguez-Papa <contact at rodsan.dev> Specifications: * SoC: MediaTek MT7621A (880 MHz 2c/4t) * RAM: Winbond W632GG6MB-12 (256M DDR3-1600) * Flash: Winbond W29N01HVSINA (128M NAND) * Eth: MediaTek MT7621A (10/100/1000 Mbps x5) * Radio: MT7603E/MT7615N (2.4 GHz & 5 GHz) 4 antennae: 1 internal and 3 non-deatachable * USB: 3.0 (x1) * LEDs: White (x1 logo) Green (x6 eth + wps) Orange (x5, hardware-bound) * Buttons: Reset (x1) WPS (x1) Installation: Flash factory image through GUI. This might fail due to the A/B nature of this device. When flashing, OEM firmware writes over the non-booted partition. If booted from 'A', flashing over 'B' won't work. To get around this, you should flash the OEM image over itself. This will then boot the router from 'B' and allow you to flash OpenWRT without problems. Reverting to factory firmware: Hard-reset the router three times to force it to boot from 'B.' This is where the stock firmware resides. To remove any traces of OpenWRT from your router simply flash the OEM image at this point. Signed-off-by: J. Scott Heppler <shep971@centurylink.net>
Diffstat (limited to 'target/linux/ramips/image/mt7621.mk')
-rw-r--r--target/linux/ramips/image/mt7621.mk9
1 files changed, 9 insertions, 0 deletions
diff --git a/target/linux/ramips/image/mt7621.mk b/target/linux/ramips/image/mt7621.mk
index 78629563ee..274d9f7158 100644
--- a/target/linux/ramips/image/mt7621.mk
+++ b/target/linux/ramips/image/mt7621.mk
@@ -655,6 +655,15 @@ define Device/linksys_ea7300-v1
endef
TARGET_DEVICES += linksys_ea7300-v1
+define Device/linksys_ea7300-v2
+ $(Device/linksys_ea7xxx)
+ DEVICE_MODEL := EA7300
+ DEVICE_VARIANT := v2
+ LINKSYS_HWNAME := EA7300v2
+ DEVICE_PACKAGES += kmod-mt7603
+endef
+TARGET_DEVICES += linksys_ea7300-v2
+
define Device/linksys_ea7500-v2
$(Device/linksys_ea7xxx)
DEVICE_MODEL := EA7500