aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image/mt7621.mk
diff options
context:
space:
mode:
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>2021-01-19 18:34:21 +0100
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2021-01-21 22:52:02 +0100
commit5a46b718260fba4253ea0153d93a02a7c3a7b710 (patch)
treef28e4c110a8d88e01a88eb222ec6afcc55ee48e5 /target/linux/ramips/image/mt7621.mk
parent36347d003a934372bf10e59645121ba387a6d27e (diff)
downloadupstream-5a46b718260fba4253ea0153d93a02a7c3a7b710.tar.gz
upstream-5a46b718260fba4253ea0153d93a02a7c3a7b710.tar.bz2
upstream-5a46b718260fba4253ea0153d93a02a7c3a7b710.zip
ramips: mt7621: reorganize shared device definitions for Xiaomi
This creates a shared device definition for Xiaomi devices with NAND and "separate" images, i.e. kernel1.bin and rootfs0.bin. This allows to consolidate similar/duplicate code for AC2100 family and Mi Router 3G. Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
Diffstat (limited to 'target/linux/ramips/image/mt7621.mk')
-rw-r--r--target/linux/ramips/image/mt7621.mk34
1 files changed, 13 insertions, 21 deletions
diff --git a/target/linux/ramips/image/mt7621.mk b/target/linux/ramips/image/mt7621.mk
index d530d5ad3e..ff39cbf39a 100644
--- a/target/linux/ramips/image/mt7621.mk
+++ b/target/linux/ramips/image/mt7621.mk
@@ -1220,39 +1220,27 @@ define Device/winstars_ws-wn583a6
endef
TARGET_DEVICES += winstars_ws-wn583a6
-define Device/xiaomi-ac2100
+define Device/xiaomi_nand_separate
$(Device/dsa-migration)
$(Device/uimage-lzma-loader)
+ DEVICE_VENDOR := Xiaomi
+ DEVICE_PACKAGES := uboot-envtools
BLOCKSIZE := 128k
PAGESIZE := 2048
KERNEL_SIZE := 4096k
- IMAGE_SIZE := 120320k
UBINIZE_OPTS := -E 5
IMAGES += kernel1.bin rootfs0.bin
IMAGE/kernel1.bin := append-kernel
IMAGE/rootfs0.bin := append-ubi | check-size
IMAGE/sysupgrade.bin := sysupgrade-tar | append-metadata
- DEVICE_VENDOR := Xiaomi
- DEVICE_PACKAGES := kmod-mt7603 kmod-mt7615e kmod-mt7615-firmware \
- uboot-envtools
endef
define Device/xiaomi_mi-router-3g
- $(Device/dsa-migration)
- $(Device/uimage-lzma-loader)
- BLOCKSIZE := 128k
- PAGESIZE := 2048
- KERNEL_SIZE := 4096k
- IMAGE_SIZE := 124416k
- UBINIZE_OPTS := -E 5
- IMAGES += kernel1.bin rootfs0.bin
- IMAGE/kernel1.bin := append-kernel
- IMAGE/rootfs0.bin := append-ubi | check-size
- IMAGE/sysupgrade.bin := sysupgrade-tar | append-metadata
- DEVICE_VENDOR := Xiaomi
+ $(Device/xiaomi_nand_separate)
DEVICE_MODEL := Mi Router 3G
- DEVICE_PACKAGES := kmod-mt7603 kmod-mt76x2 kmod-usb3 \
- kmod-usb-ledtrig-usbport uboot-envtools
+ IMAGE_SIZE := 124416k
+ DEVICE_PACKAGES += kmod-mt7603 kmod-mt76x2 kmod-usb3 \
+ kmod-usb-ledtrig-usbport
SUPPORTED_DEVICES += R3G mir3g xiaomi,mir3g
endef
TARGET_DEVICES += xiaomi_mi-router-3g
@@ -1301,14 +1289,18 @@ endef
TARGET_DEVICES += xiaomi_mi-router-4a-gigabit
define Device/xiaomi_mi-router-ac2100
- $(Device/xiaomi-ac2100)
+ $(Device/xiaomi_nand_separate)
DEVICE_MODEL := Mi Router AC2100
+ IMAGE_SIZE := 120320k
+ DEVICE_PACKAGES += kmod-mt7603 kmod-mt7615e kmod-mt7615-firmware
endef
TARGET_DEVICES += xiaomi_mi-router-ac2100
define Device/xiaomi_redmi-router-ac2100
- $(Device/xiaomi-ac2100)
+ $(Device/xiaomi_nand_separate)
DEVICE_MODEL := Redmi Router AC2100
+ IMAGE_SIZE := 120320k
+ DEVICE_PACKAGES += kmod-mt7603 kmod-mt7615e kmod-mt7615-firmware
endef
TARGET_DEVICES += xiaomi_redmi-router-ac2100