aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image/mt7621.mk
diff options
context:
space:
mode:
authorIgor Nazarov <tigron.dev@gmail.com>2022-03-17 00:51:35 +0300
committerHauke Mehrtens <hauke@hauke-m.de>2022-03-19 19:51:20 +0100
commit42626aef676d2ca1ea1577b7a47ba8e4135f1a4c (patch)
treeffc5ce3e299072e2945dee7e8e65e3c41a9045b8 /target/linux/ramips/image/mt7621.mk
parent1eb5d50fd3dff15a2e316fcfa3c25597be429526 (diff)
downloadupstream-42626aef676d2ca1ea1577b7a47ba8e4135f1a4c.tar.gz
upstream-42626aef676d2ca1ea1577b7a47ba8e4135f1a4c.tar.bz2
upstream-42626aef676d2ca1ea1577b7a47ba8e4135f1a4c.zip
ramips: add support for D-Link DIR-878 R1
Specifications: - SoC: MediaTek MT7621AT - RAM: 128 MB (DDR3) - Flash: 16 MB (SPI NOR) - WiFi: MT7615N (2.4GHz) and MT7615N (5Ghz) - Switch: 1 WAN, 4 LAN (Gigabit) - Buttons: Reset, WiFi Toggle, WPS - LEDs: Power, Internet, WiFi 2.4G WiFi 5G The R1 revision is identical to the A1 revision except - No Config2 Parition, therefore - factory partition resized to 64k from 128K - Firmware partition offset is 0x50000 not 0x60000 - Firmware partitions size increased by 64K - Firmware partition type is "denx,uimage", not "sge,uimage" - Padding of image creation "uimage-padhdr 96" removed Installation: Update to the last D-Link firmware through web-ui before OpenWRT installation then follow the instructions to patch your device using D-Link FailsafeUI. - D-Link FailsafeUI: Power down the router, press and hold the reset button, then re-plug it. Keep the reset button pressed until the internet LED stops flashing, then jack into any lan port and manually assign a static IP address in 192.168.0.0/24 other than 192.168.0.1 (e.g. 192.168.0.2) and go to http://192.168.0.1 Flash with the factory image. Signed-off-by: Igor Nazarov <tigron.dev@gmail.com>
Diffstat (limited to 'target/linux/ramips/image/mt7621.mk')
-rw-r--r--target/linux/ramips/image/mt7621.mk11
1 files changed, 11 insertions, 0 deletions
diff --git a/target/linux/ramips/image/mt7621.mk b/target/linux/ramips/image/mt7621.mk
index 8bef3a1bfb..cd28e36917 100644
--- a/target/linux/ramips/image/mt7621.mk
+++ b/target/linux/ramips/image/mt7621.mk
@@ -409,6 +409,17 @@ define Device/dlink_dir-878-a1
endef
TARGET_DEVICES += dlink_dir-878-a1
+define Device/dlink_dir-878-r1
+ $(Device/dlink_dir-8xx-r1)
+ DEVICE_MODEL := DIR-878
+ DEVICE_VARIANT := R1
+ IMAGES += factory.bin
+ IMAGE/factory.bin := append-kernel | append-rootfs | check-size | \
+ sign-dlink-ru 57c5375741c30ca9ebcb36713db4ba51 \
+ ab0dff19af8842cdb70a86b4b68d23f7
+endef
+TARGET_DEVICES += dlink_dir-878-r1
+
define Device/dlink_dir-882-a1
$(Device/dlink_dir-8xx-a1)
DEVICE_MODEL := DIR-882