aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image/mt7621.mk
diff options
context:
space:
mode:
authorJohn Thomson <git@johnthomson.fastmail.com.au>2020-10-15 19:27:55 +1000
committerChuanhong Guo <gch981213@gmail.com>2020-10-29 21:35:03 +0800
commit254f51443ddaee873267d41993b5bbc4b5ef7959 (patch)
treeb89d530c02a666c6802945671fa144749391f809 /target/linux/ramips/image/mt7621.mk
parent9a168b51c3a60c95ccd349dd3010615ba6b0e033 (diff)
downloadupstream-254f51443ddaee873267d41993b5bbc4b5ef7959.tar.gz
upstream-254f51443ddaee873267d41993b5bbc4b5ef7959.tar.bz2
upstream-254f51443ddaee873267d41993b5bbc4b5ef7959.zip
mt7621: mikrotik: use vmlinuz (zBoot ELF)
- minimal built initramfs: 11MB vmlinux ELF -> 4.5MB vmlinuz - ~5 seconds for kernel decompression, which was equivalent to the additional time to load the uncompressed ELF from SPI NOR. - Removes requirement for lzma-loader, which may have been causing some image builds to fail to boot on Mikrotik mt7621. Fixes: FS#3354 Suggested-by: Thibaut VARĂˆNE <hacks@slashdirt.org> Signed-off-by: John Thomson <git@johnthomson.fastmail.com.au>
Diffstat (limited to 'target/linux/ramips/image/mt7621.mk')
-rw-r--r--target/linux/ramips/image/mt7621.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/target/linux/ramips/image/mt7621.mk b/target/linux/ramips/image/mt7621.mk
index 8919d764b0..bb7e5a0d48 100644
--- a/target/linux/ramips/image/mt7621.mk
+++ b/target/linux/ramips/image/mt7621.mk
@@ -708,8 +708,8 @@ define Device/MikroTik
BLOCKSIZE := 64k
IMAGE_SIZE := 16128k
DEVICE_PACKAGES := kmod-usb3
- LOADER_TYPE := elf
- KERNEL := $(KERNEL_DTB) | loader-kernel
+ KERNEL_NAME := vmlinuz
+ KERNEL := kernel-bin | append-dtb-elf
IMAGE/sysupgrade.bin := append-kernel | kernel2minor -s 1024 | \
pad-to $$$$(BLOCKSIZE) | append-rootfs | pad-rootfs | append-metadata | \
check-size