aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image/mt7621.mk
diff options
context:
space:
mode:
authorAashish Kulkarni <aashishkul@gmail.com>2021-03-02 10:40:14 +0530
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2021-06-05 23:39:14 +0200
commit251c995cbb1ea5ad1de14775312c2bd19ed10439 (patch)
treef37808d71d9de66fd25f2fec66bfe549ec1f7dc8 /target/linux/ramips/image/mt7621.mk
parentb126d9c3a3d3c8fe0937bcdfffabe8df941d2c06 (diff)
downloadupstream-251c995cbb1ea5ad1de14775312c2bd19ed10439.tar.gz
upstream-251c995cbb1ea5ad1de14775312c2bd19ed10439.tar.bz2
upstream-251c995cbb1ea5ad1de14775312c2bd19ed10439.zip
ramips: add support for Linksys E5600
This submission relied heavily on the work of Linksys EA7300 v1/ v2. Specifications: * SoC: MediaTek MT7621A (880 MHz 2c/4t) * RAM: 128M DDR3-1600 * Flash: 128M NAND * Eth: MediaTek MT7621A (10/100/1000 Mbps x5) * Radio: MT7603E/MT7613BE (2.4 GHz & 5 GHz) * Antennae: 2 internal fixed in the casing and 2 on the PCB * LEDs: Blue (x4 Ethernet) Blue+Orange (x2 Power + WPS and Internet) * Buttons: Reset (x1) WPS (x1) Installation: Flash factory image through GUI. This device has 2 partitions for the firmware called firmware and alt_firmware. To successfully flash and boot the device, the device should have been running from alt_firmware partition. To get the device booted through alt_firmware partition, download the OEM firmware from Linksys website and upgrade the firmware from web GUI. Once this is done, flash the OpenWrt Factory firmware from web GUI. Reverting to factory firmware: 1. Boot to 'alt_firmware'(where stock firmware resides) by doing one of the following: Press the "wps" button as soon as power LED turns on when booting. (OR) Hard-reset the router consecutively three times to force it to boot from 'alt_firmware'. 2. To remove any traces of OpenWRT from your router simply flash the OEM image at this point. Signed-off-by: Aashish Kulkarni <aashishkul@gmail.com> [fix hanging indents and wrap to 74 characters per line, add kmod-mt7663-firmware-sta package for 5GHz STA mode to work, remove sysupgrade.bin and concatenate IMAGES instead in mt7621.mk, set default-state "on" for power LED] Signed-off-by: Sannihith Kinnera <digislayer@protonmail.com> [move check-size before append-metadata, remove trailing whitespace] Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
Diffstat (limited to 'target/linux/ramips/image/mt7621.mk')
-rw-r--r--target/linux/ramips/image/mt7621.mk23
1 files changed, 23 insertions, 0 deletions
diff --git a/target/linux/ramips/image/mt7621.mk b/target/linux/ramips/image/mt7621.mk
index 20433f783d..04f84ac1fe 100644
--- a/target/linux/ramips/image/mt7621.mk
+++ b/target/linux/ramips/image/mt7621.mk
@@ -22,6 +22,10 @@ define Build/elecom-wrc-gs-factory
mv $@.new $@
endef
+define Build/gemtek-trailer
+ printf "%s%08X" ".GEMTEK." "$$(cksum $@ | cut -d ' ' -f1)" >> $@
+endef
+
define Build/iodata-factory
$(eval fw_size=$(word 1,$(1)))
$(eval fw_type=$(word 2,$(1)))
@@ -762,6 +766,25 @@ define Device/lenovo_newifi-d1
endef
TARGET_DEVICES += lenovo_newifi-d1
+define Device/linksys_e5600
+ $(Device/dsa-migration)
+ $(Device/uimage-lzma-loader)
+ BLOCKSIZE := 128k
+ PAGESIZE := 2048
+ KERNEL_SIZE := 4096k
+ IMAGE_SIZE := 26624k
+ DEVICE_VENDOR := Linksys
+ DEVICE_MODEL := E5600
+ DEVICE_PACKAGES := kmod-mt7603 kmod-mt7615e kmod-mt7663-firmware-ap \
+ kmod-mt7663-firmware-sta uboot-envtools
+ UBINIZE_OPTS := -E 5
+ IMAGES += factory.bin
+ IMAGE/sysupgrade.bin := sysupgrade-tar | check-size | append-metadata
+ IMAGE/factory.bin := append-kernel | pad-to $$$$(KERNEL_SIZE) | \
+ append-ubi | check-size | gemtek-trailer
+endef
+TARGET_DEVICES += linksys_e5600
+
define Device/linksys_ea7xxx
$(Device/dsa-migration)
$(Device/uimage-lzma-loader)