aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image/mt7621.mk
diff options
context:
space:
mode:
authorChuanhong Guo <gch981213@gmail.com>2020-10-21 13:11:35 +0800
committerChuanhong Guo <gch981213@gmail.com>2020-10-25 22:27:44 +0800
commit23be410b3d1267c752bf9f6e5c8f5a514dc562c4 (patch)
tree0ea624482cafef5f1b8f936258b5598a0d4246d6 /target/linux/ramips/image/mt7621.mk
parent70c17268a8b740448791bb6840f3eb79a64939c0 (diff)
downloadupstream-23be410b3d1267c752bf9f6e5c8f5a514dc562c4.tar.gz
upstream-23be410b3d1267c752bf9f6e5c8f5a514dc562c4.tar.bz2
upstream-23be410b3d1267c752bf9f6e5c8f5a514dc562c4.zip
ramips: add support for TOTOLINK X5000R
Specifications: - SoC: MT7621AT - RAM: 256MB - Flash: 16MB (EN25QH128A) - Ethernet: 5xGbE - WiFi: MT7915 2x2 2.4G 573.5Mbps + 2x2 5G 1201Mbps Known issue: MT7915 DBDC variant isn't supported yet. Flash instruction: Upload the sysupgrade firmware to the firmware upgrade page in vendor fw. Other info: MT7915 seems to have two PCIEs connected to MT7621. Card detected on PCIE0 has an ID of 14c3:7916 and the other one on PCIE1 has 14c3:7915. Signed-off-by: Chuanhong Guo <gch981213@gmail.com>
Diffstat (limited to 'target/linux/ramips/image/mt7621.mk')
-rw-r--r--target/linux/ramips/image/mt7621.mk10
1 files changed, 10 insertions, 0 deletions
diff --git a/target/linux/ramips/image/mt7621.mk b/target/linux/ramips/image/mt7621.mk
index 274d9f7158..7a97f8aa73 100644
--- a/target/linux/ramips/image/mt7621.mk
+++ b/target/linux/ramips/image/mt7621.mk
@@ -1015,6 +1015,16 @@ define Device/totolink_a7000r
endef
TARGET_DEVICES += totolink_a7000r
+define Device/totolink_x5000r
+ $(Device/dsa-migration)
+ IMAGE_SIZE := 16064k
+ UIMAGE_NAME := C8343R-9999
+ DEVICE_VENDOR := TOTOLINK
+ DEVICE_MODEL := X5000R
+ DEVICE_PACKAGES := kmod-mt7915e
+endef
+TARGET_DEVICES += totolink_x5000r
+
define Device/tplink_re350-v1
$(Device/dsa-migration)
$(Device/tplink-safeloader)