aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image/mt7621.mk
diff options
context:
space:
mode:
authorDaniel Danzberger <daniel@dd-wrt.com>2019-06-25 10:58:25 +0200
committerChristian Lamparter <chunkeey@gmail.com>2019-06-25 15:02:21 +0200
commit029c97046468e4a793b5332e999aa42c2e74c84e (patch)
tree2cbbff31f9c6644d619430518408c3aed2e39510 /target/linux/ramips/image/mt7621.mk
parent487c6863183f34ebaa4d822b45782c287a72009d (diff)
downloadupstream-029c97046468e4a793b5332e999aa42c2e74c84e.tar.gz
upstream-029c97046468e4a793b5332e999aa42c2e74c84e.tar.bz2
upstream-029c97046468e4a793b5332e999aa42c2e74c84e.zip
ramips: mt7621: Add new device AsiaRF AP7621-001
Hardware specs: SoC: Mediatek MT7621A CPU: 4x 880Mhz Cache: 32 KB I-Cache and 32 KB D-Cach 256 KB L2 Cache (shared by Dual-Core) RAM: DDR3 512MB 16bits BUS FLASH: 16MB Switch: Mediatek Gigabit Switch (1 x LAN, 1 x WAN) USB: 1x 3.0 PCI: 3x Mini PCIe GPS: Quectel L70B BTN: Reset LED: - Power - Ethernet - Wifi - USB UART: UART is present as Pads with throughholes on the PCB. They are located on left side. 3.3V - RX - GND - TX / 57600-8N1 3.3V is the square pad Installation: The stock image is a modified openwrt and can be overflashed via # sysupgrade -F image.bin Signed-off-by: Daniel Danzberger <daniel@dd-wrt.com> Signed-off-by: Christian Lamparter <chunkeey@gmail.com> [removed unused label, formatting]
Diffstat (limited to 'target/linux/ramips/image/mt7621.mk')
-rw-r--r--target/linux/ramips/image/mt7621.mk10
1 files changed, 10 insertions, 0 deletions
diff --git a/target/linux/ramips/image/mt7621.mk b/target/linux/ramips/image/mt7621.mk
index 2eb7feb5bf..c1e445f84c 100644
--- a/target/linux/ramips/image/mt7621.mk
+++ b/target/linux/ramips/image/mt7621.mk
@@ -640,3 +640,13 @@ define Device/zbt-wg3526-32M
kmod-usb3 kmod-usb-ledtrig-usbport wpad-basic
endef
TARGET_DEVICES += zbt-wg3526-32M
+
+define Device/asiarf_ap7621-001
+ DTS := AP7621-001
+ IMAGE_SIZE := $(ralink_default_fw_size_16M)
+ DEVICE_TITLE := AsiaRF AP7621-001
+ DEVICE_PACKAGES := \
+ kmod-sdhci-mt7620 kmod-mt76x2 kmod-usb3
+endef
+TARGET_DEVICES += asiarf_ap7621-001
+