aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image/mt7620.mk
diff options
context:
space:
mode:
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-06-09 12:31:57 +0200
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-06-11 01:41:43 +0200
commitfbb46b7bcc24e5ef2581930e2a9b3996e4381f97 (patch)
tree337a7b4b0ab2255ffd0c27bfc3d9b0a48e074bb4 /target/linux/ramips/image/mt7620.mk
parent69f6fc7b15875e7657cd56ef69731cde41f677a0 (diff)
downloadupstream-fbb46b7bcc24e5ef2581930e2a9b3996e4381f97.tar.gz
upstream-fbb46b7bcc24e5ef2581930e2a9b3996e4381f97.tar.bz2
upstream-fbb46b7bcc24e5ef2581930e2a9b3996e4381f97.zip
ramips: add support for Netgear EX6120
Specifications: * SoC: MT7620A * CPU: 580 MHz * RAM: 64 MB DDR * Flash: 8MB NOR SPI flash * WiFi: MT7612E (5GHz) and builtin MT7620A (2.4GHz) * LAN: 1x100M The device is identical to the EX6130 except for the mains socket and the hardware ID. Installation: The -factory images can be flashed from the device's web interface or via nmrpflash. Notes: MAC addresses were set up based on the EX6130 setup. This is based on prior work of Adam Serbinski and Mathias Buchwald. Tested by Mathias Buchwald. Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
Diffstat (limited to 'target/linux/ramips/image/mt7620.mk')
-rw-r--r--target/linux/ramips/image/mt7620.mk13
1 files changed, 13 insertions, 0 deletions
diff --git a/target/linux/ramips/image/mt7620.mk b/target/linux/ramips/image/mt7620.mk
index 386809e40f..df3f050048 100644
--- a/target/linux/ramips/image/mt7620.mk
+++ b/target/linux/ramips/image/mt7620.mk
@@ -670,6 +670,19 @@ define Device/netgear_ex3700
endef
TARGET_DEVICES += netgear_ex3700
+define Device/netgear_ex6120
+ SOC := mt7620a
+ NETGEAR_BOARD_ID := U12H319T30_NETGEAR
+ BLOCKSIZE := 4k
+ IMAGE_SIZE := 7744k
+ IMAGES += factory.chk
+ IMAGE/factory.chk := $$(sysupgrade_bin) | check-size | netgear-chk
+ DEVICE_PACKAGES := kmod-mt76x2
+ DEVICE_VENDOR := NETGEAR
+ DEVICE_MODEL := EX6120
+endef
+TARGET_DEVICES += netgear_ex6120
+
define Device/netgear_ex6130
SOC := mt7620a
NETGEAR_BOARD_ID := U12H319T50_NETGEAR