aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image/mt7620.mk
diff options
context:
space:
mode:
authorDaniel Gimpelevich <daniel@gimpelevich.san-francisco.ca.us>2018-07-16 07:19:19 -0700
committerJohn Crispin <john@phrozen.org>2018-08-06 07:05:37 +0200
commitf72fa883b324311c1972c39ed521e536b25d674c (patch)
treec586f1a9c384205b04569e75d4d86d99f3346b7b /target/linux/ramips/image/mt7620.mk
parentad5c2897ec054b80549e526ef639dd75548d4747 (diff)
downloadupstream-f72fa883b324311c1972c39ed521e536b25d674c.tar.gz
upstream-f72fa883b324311c1972c39ed521e536b25d674c.tar.bz2
upstream-f72fa883b324311c1972c39ed521e536b25d674c.zip
ramips: add support for Edimax BR-6478AC v2
Roll-up of patches by Rohan Murch, Hans Ulli Kroll, and James McKenzie. Taken from https://forum.openwrt.org/viewtopic.php?id=67192 and updated. Specification: - System-On-Chip: MT7620A - CPU/Speed: 580 MHz - Flash-Chip: Macronix MX25L6405D - Flash size: 8192 KiB - RAM: 64 MiB - Wireless No1: SoC-integrated: MT7620A 2.4GHz 802.11bgn - Wireless No2: On-board chip: MT7612E 5GHz 802.11ac - Switch: Mediatek MT7530W Gigabit Switch - USB: Yes 1 x 2.0 Installation: 1. Download sysupgrade.bin 2. Open vendor web interface 3. Choose to upgrade firmware 4. After reboot connect via ethernet at 192.168.1.1 Signed-off-by: Daniel Gimpelevich <daniel@gimpelevich.san-francisco.ca.us>
Diffstat (limited to 'target/linux/ramips/image/mt7620.mk')
-rw-r--r--target/linux/ramips/image/mt7620.mk12
1 files changed, 12 insertions, 0 deletions
diff --git a/target/linux/ramips/image/mt7620.mk b/target/linux/ramips/image/mt7620.mk
index c968825754..0edea9f13c 100644
--- a/target/linux/ramips/image/mt7620.mk
+++ b/target/linux/ramips/image/mt7620.mk
@@ -475,6 +475,18 @@ define Device/tiny-ac
endef
TARGET_DEVICES += tiny-ac
+define Device/br-6478ac-v2
+ DTS := BR-6478AC-V2
+ DEVICE_TITLE := Edimax BR-6478AC V2
+ BLOCKSIZE := 64k
+ IMAGE_SIZE := 7616k
+ IMAGE/sysupgrade.bin := append-kernel | append-rootfs | \
+ edimax-header -s CSYS -m RN68 -f 0x70000 -S 0x01100000 | pad-rootfs | \
+ append-metadata | check-size $$$$(IMAGE_SIZE)
+ DEVICE_PACKAGES := kmod-mt76
+endef
+TARGET_DEVICES += br-6478ac-v2
+
define Device/tplink_c2-v1
$(Device/Archer)
DTS := ArcherC2-v1