aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image/mt7620.mk
diff options
context:
space:
mode:
authorChuanhong Guo <gch981213@gmail.com>2020-04-09 18:40:01 +0800
committerChuanhong Guo <gch981213@gmail.com>2020-04-12 22:27:18 +0800
commitd7d46da938e3f5c4ace815870c95f67d8b663ebe (patch)
treea98918ad84f4744246d07fd5a3c0426de8aee8d0 /target/linux/ramips/image/mt7620.mk
parente29e2a94845141e5c9758351c7dffa1145c5d3b5 (diff)
downloadupstream-d7d46da938e3f5c4ace815870c95f67d8b663ebe.tar.gz
upstream-d7d46da938e3f5c4ace815870c95f67d8b663ebe.tar.bz2
upstream-d7d46da938e3f5c4ace815870c95f67d8b663ebe.zip
ramips: disable images for 4M devices
default initramfs for 5.4 kernel is larger than 4M, causing build error for oversized initramfs image. disable these images because we have no mechanism for ignoring initramfs errors and the squashfs image will be larger than initramfs anyway. Signed-off-by: Chuanhong Guo <gch981213@gmail.com>
Diffstat (limited to 'target/linux/ramips/image/mt7620.mk')
-rw-r--r--target/linux/ramips/image/mt7620.mk2
1 files changed, 2 insertions, 0 deletions
diff --git a/target/linux/ramips/image/mt7620.mk b/target/linux/ramips/image/mt7620.mk
index d5365ac70e..818fd12de7 100644
--- a/target/linux/ramips/image/mt7620.mk
+++ b/target/linux/ramips/image/mt7620.mk
@@ -687,6 +687,7 @@ define Device/nexx_wt3020-4m
DEVICE_MODEL := WT3020
DEVICE_VARIANT := 4M
SUPPORTED_DEVICES += wt3020 wt3020-4M
+ DEFAULT := n
endef
TARGET_DEVICES += nexx_wt3020-4m
@@ -975,6 +976,7 @@ define Device/vonets_var11n-300
BLOCKSIZE := 4k
DEVICE_VENDOR := Vonets
DEVICE_MODEL := VAR11N-300
+ DEFAULT := n
endef
TARGET_DEVICES += vonets_var11n-300