aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image/mt7620.mk
diff options
context:
space:
mode:
authorPawel Dembicki <paweldembicki@gmail.com>2018-11-17 08:47:40 +0000
committerJohn Crispin <john@phrozen.org>2018-11-26 12:16:52 +0100
commit20b09a2125f5b35ade1f3e9cebb15fe03e3b4e3c (patch)
tree514411700431f59bb7f7b6aa5141338f7e4498df /target/linux/ramips/image/mt7620.mk
parentb85fe43ec8c4d4aa34d3c0bbb3e57da3f176526b (diff)
downloadupstream-20b09a2125f5b35ade1f3e9cebb15fe03e3b4e3c.tar.gz
upstream-20b09a2125f5b35ade1f3e9cebb15fe03e3b4e3c.tar.bz2
upstream-20b09a2125f5b35ade1f3e9cebb15fe03e3b4e3c.zip
ramips: add support for Lava LR-25G001
The Lava LR-25G001 Wireless Router is based on the MT7620A SoC. Specification: - MediaTek MT7620A (580 Mhz) - 64 MB of RAM - 16 MB of FLASH - 1x 802.11bgn radio - 1x 802.11ac radio (MT7610EN) - 5x 10/100/1000 Mbps AR8337 Switch (1 WAN AND 4 LAN) - 2x external, detachable antennas - 1x USB 2.0 - UART (J3) header on PCB (57600 8n1) - 8x LED (3x GPIO-controlled), 2x button - JBOOT bootloader Known issues: - Work only three Gigabit ports (3/5, 1 WAN and 2LAN) Installation: Apply factory image via http web-gui or JBOOT recovery page How to revert to OEM firmware: - push the reset button and turn on the power. Wait until LED start blinking (~10sec.) - upload original factory image via JBOOT http (IP: 192.168.123.254) Signed-off-by: Pawel Dembicki <paweldembicki@gmail.com>
Diffstat (limited to 'target/linux/ramips/image/mt7620.mk')
-rw-r--r--target/linux/ramips/image/mt7620.mk15
1 files changed, 15 insertions, 0 deletions
diff --git a/target/linux/ramips/image/mt7620.mk b/target/linux/ramips/image/mt7620.mk
index 61a6e56937..5e3d37b5c8 100644
--- a/target/linux/ramips/image/mt7620.mk
+++ b/target/linux/ramips/image/mt7620.mk
@@ -352,6 +352,21 @@ define Device/microwrt
endef
TARGET_DEVICES += microwrt
+define Device/lava_lr-25g001
+ DTS := LR-25G001
+ DEVICE_TITLE := LAVA LR-25G001
+ DLINK_ROM_ID := LVA6E3804001
+ DLINK_FAMILY_MEMBER := 0x6E38
+ DLINK_FIRMWARE_SIZE := 0xFE0000
+ KERNEL := $(KERNEL_DTB)
+ IMAGES += factory.bin
+ IMAGE/sysupgrade.bin := mkdlinkfw | pad-rootfs | append-metadata
+ IMAGE/factory.bin := mkdlinkfw | pad-rootfs | mkdlinkfw-factory
+ DEVICE_PACKAGES := jboot-tools kmod-usb2 kmod-mt76 kmod-mt76x0-common \
+ kmod-mt76x0e
+endef
+TARGET_DEVICES += lava_lr-25g001
+
define Device/miwifi-mini
DTS := MIWIFI-MINI
IMAGE_SIZE := $(ralink_default_fw_size_16M)