aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image/Makefile
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2012-03-29 16:03:04 +0000
committerJo-Philipp Wich <jow@openwrt.org>2012-03-29 16:03:04 +0000
commite9c4d3d1f2dd990ebd9474ceda1c77b45678c6bd (patch)
tree1c8f859fa4472105030accbb677d1e617b286e51 /target/linux/ramips/image/Makefile
parentde0527a354426c4da678866cc3c1ab5d3f940a0c (diff)
downloadupstream-e9c4d3d1f2dd990ebd9474ceda1c77b45678c6bd.tar.gz
upstream-e9c4d3d1f2dd990ebd9474ceda1c77b45678c6bd.tar.bz2
upstream-e9c4d3d1f2dd990ebd9474ceda1c77b45678c6bd.zip
ramips: add support for the ARC FreeStation5 board, also fix WCR-150GN network setup while we're at it - thanks Pau Escrich <p4u@dabax.net> for the implementation
SVN-Revision: 31144
Diffstat (limited to 'target/linux/ramips/image/Makefile')
-rw-r--r--target/linux/ramips/image/Makefile5
1 files changed, 5 insertions, 0 deletions
diff --git a/target/linux/ramips/image/Makefile b/target/linux/ramips/image/Makefile
index a4d526df18..0c37f7e352 100644
--- a/target/linux/ramips/image/Makefile
+++ b/target/linux/ramips/image/Makefile
@@ -331,6 +331,10 @@ define Image/Build/Profile/FONERA20N
$(call Image/Build/Template/$(fs_squash)/$(1),FONERA20N)
endef
+define Image/Build/Profile/FREESTATION5
+ $(call Image/Build/Template/$(fs_squash)/$(1),GENERIC_8M,freestation5,FREESTATION5,ttyS1,115200,phys)
+endef
+
define Image/Build/Profile/MOFI35003GN
$(call Image/Build/Template/$(fs_squash)/$(1),GENERIC_8M,mofi3500-3gn,MOFI3500-3GN,ttyS1,57600,phys)
endef
@@ -414,6 +418,7 @@ define Image/Build/Profile/Default
$(call Image/Build/Profile/F5D8235V2,$(1))
$(call Image/Build/Profile/RTN10PLUS,$(1))
$(call Image/Build/Profile/FONERA20N,$(1))
+ $(call Image/Build/Profile/FREESTATION5,$(1))
$(call Image/Build/Profile/HW5503G,$(1))
$(call Image/Build/Profile/MOFI35003GN,$(1))
$(call Image/Build/Profile/NBG419N,$(1))