aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image/Makefile
diff options
context:
space:
mode:
authorYanase Yuki <dev@zpc.sakura.ne.jp>2020-11-05 19:59:06 +0900
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2021-02-05 21:57:19 +0100
commitd468ff97b71994d5f30751fdd22c530c85a52f42 (patch)
treef9b71d436dfe231e68de29db26ae1bfc0c56101d /target/linux/ramips/image/Makefile
parent321035420cb7c5bb5fd53879824d2886a6f288e8 (diff)
downloadupstream-d468ff97b71994d5f30751fdd22c530c85a52f42.tar.gz
upstream-d468ff97b71994d5f30751fdd22c530c85a52f42.tar.bz2
upstream-d468ff97b71994d5f30751fdd22c530c85a52f42.zip
build: move elx-header into image-commands.mk
ELECOM WAB-I1750-PS will need this in ath79, so move it to common Makefile. Signed-off-by: Yanase Yuki <dev@zpc.sakura.ne.jp>
Diffstat (limited to 'target/linux/ramips/image/Makefile')
-rw-r--r--target/linux/ramips/image/Makefile20
1 files changed, 0 insertions, 20 deletions
diff --git a/target/linux/ramips/image/Makefile b/target/linux/ramips/image/Makefile
index 2fb13dcf08..21bd135a62 100644
--- a/target/linux/ramips/image/Makefile
+++ b/target/linux/ramips/image/Makefile
@@ -35,26 +35,6 @@ define Build/edimax-header
@mv $@.new $@
endef
-define Build/elx-header
- $(eval hw_id=$(word 1,$(1)))
- $(eval xor_pattern=$(word 2,$(1)))
- ( \
- echo -ne "\x00\x00\x00\x00\x00\x00\x00\x03" | \
- dd bs=42 count=1 conv=sync; \
- hw_id="$(hw_id)"; \
- echo -ne "\x$${hw_id:0:2}\x$${hw_id:2:2}\x$${hw_id:4:2}\x$${hw_id:6:2}" | \
- dd bs=20 count=1 conv=sync; \
- echo -ne "$$(printf '%08x' $$(stat -c%s $@) | fold -s2 | xargs -I {} echo \\x{} | tr -d '\n')" | \
- dd bs=8 count=1 conv=sync; \
- echo -ne "$$($(STAGING_DIR_HOST)/bin/mkhash md5 $@ | fold -s2 | xargs -I {} echo \\x{} | tr -d '\n')" | \
- dd bs=58 count=1 conv=sync; \
- ) > $(KDIR)/tmp/$(DEVICE_NAME).header
- $(call Build/xor-image,-p $(xor_pattern) -x)
- cat $(KDIR)/tmp/$(DEVICE_NAME).header $@ > $@.new
- mv $@.new $@
- rm -rf $(KDIR)/tmp/$(DEVICE_NAME).header
-endef
-
define Build/jcg-header
$(STAGING_DIR_HOST)/bin/jcgimage -v $(1) \
$(if $(JCG_MAXSIZE), -m $$(($(subst k, * 1024,$(JCG_MAXSIZE)))),) \