aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image/Makefile
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2014-04-22 08:08:51 +0000
committerJohn Crispin <john@openwrt.org>2014-04-22 08:08:51 +0000
commitcd5f3584e2c2044c2cd53d723350a8d02b227aff (patch)
tree3095f0a68cfbd8e96d0a23d86608057aba1302fd /target/linux/ramips/image/Makefile
parent4f3c74011048239eb5c37a2740c428b59d161387 (diff)
downloadupstream-cd5f3584e2c2044c2cd53d723350a8d02b227aff.tar.gz
upstream-cd5f3584e2c2044c2cd53d723350a8d02b227aff.tar.bz2
upstream-cd5f3584e2c2044c2cd53d723350a8d02b227aff.zip
ramips: Add support for the 7Links PX-4885 wireless router.
The 7Links PX-4885 is a small battery-powered wireless router. It is based on a RT5350F WiSoC and features one ethernet port and one USB port. It is a Hame MPR-A1 clone, except it has different GPIOs, a different battery and more RAM (32 MB). This patch adds a profile for this board, the corresponding device tree file and the adequate base-files changes (incl. sysupgrade). Signed-off-by: Hugo Grostabussiat <bonstra@bonstra.fr.eu.org> SVN-Revision: 40554
Diffstat (limited to 'target/linux/ramips/image/Makefile')
-rw-r--r--target/linux/ramips/image/Makefile3
1 files changed, 3 insertions, 0 deletions
diff --git a/target/linux/ramips/image/Makefile b/target/linux/ramips/image/Makefile
index 26386bf05c..19932f6fe1 100644
--- a/target/linux/ramips/image/Makefile
+++ b/target/linux/ramips/image/Makefile
@@ -448,6 +448,8 @@ Image/Build/Profile/PSR-680W=$(call BuildFirmware/Default4M/$(1),$(1),psr-680w,P
Image/Build/Profile/PWH2004=$(call BuildFirmware/Default8M/$(1),$(1),pwh2004,PWH2004)
+Image/Build/Profile/PX4885=$(call BuildFirmware/Default4M/$(1),$(1),px4885,PX4885)
+
Image/Build/Profile/RTG32B1=$(call BuildFirmware/Default4M/$(1),$(1),rt-g32-b1,RT-G32-B1)
Image/Build/Profile/RTN10PLUS=$(call BuildFirmware/Default4M/$(1),$(1),rt-n10-plus,RT-N10-PLUS)
@@ -585,6 +587,7 @@ define Image/Build/Profile/Default
$(call Image/Build/Profile/OMNI-EMB,$(1))
$(call Image/Build/Profile/PSR-680W,$(1))
$(call Image/Build/Profile/PWH2004,$(1))
+ $(call Image/Build/Profile/PX4885,$(1))
$(call Image/Build/Profile/RTG32B1,$(1))
$(call Image/Build/Profile/RTN10PLUS,$(1))
$(call Image/Build/Profile/RT-N13U,$(1))