aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image/Makefile
diff options
context:
space:
mode:
authorPawel Dembicki <paweldembicki@gmail.com>2018-01-20 09:27:03 +0100
committerMathias Kresin <dev@kresin.me>2018-03-18 22:22:38 +0100
commita5bd8de0bd80b83e43ce90ddc6623890344ad33d (patch)
tree010dcb56db1833675cdc6012b21a42f6062de46b /target/linux/ramips/image/Makefile
parent5323477184cf39f4f20003142ce320ac1d626863 (diff)
downloadupstream-a5bd8de0bd80b83e43ce90ddc6623890344ad33d.tar.gz
upstream-a5bd8de0bd80b83e43ce90ddc6623890344ad33d.tar.bz2
upstream-a5bd8de0bd80b83e43ce90ddc6623890344ad33d.zip
ramips: add support for D-Link DWR-116-A1/2
The DWR-116-A1/2 Wireless Router is based on the MT7620N SoC. Specification: MediaTek MT7620N (580 Mhz) 32 MB of RAM 8 MB of FLASH 802.11bgn radio 5x 10/100 Mbps Ethernet (1 WAN and 4 LAN) 2x external, non-detachable antennas UART (J1 in A1, JP1 in A2) header on PCB (57600 8n1) 6x LED (GPIO-controlled), 2x button JBOOT bootloader Known issues: WAN LED is drived by uartl tx pin. I decide to use this pin as uartlite tx pin. Installation: Apply factory image via http web-gui. Signed-off-by: Pawel Dembicki <paweldembicki@gmail.com>
Diffstat (limited to 'target/linux/ramips/image/Makefile')
-rw-r--r--target/linux/ramips/image/Makefile20
1 files changed, 20 insertions, 0 deletions
diff --git a/target/linux/ramips/image/Makefile b/target/linux/ramips/image/Makefile
index abcff03629..13934c5b06 100644
--- a/target/linux/ramips/image/Makefile
+++ b/target/linux/ramips/image/Makefile
@@ -111,6 +111,26 @@ define Build/wrg-header
mv $@.new $@
endef
+# combine kernel and rootfs into one image
+# mkdlinkfw <type> <optional extra arguments to mkdlinkfw binary>
+
+define Build/mkdlinkfw
+ -$(STAGING_DIR_HOST)/bin/mkdlinkfw \
+ -k $(IMAGE_KERNEL) \
+ -r $(IMAGE_ROOTFS) \
+ -o $@ \
+ -s $(DLINK_FIRMWARE_SIZE)
+endef
+
+define Build/mkdlinkfw-factory
+ -$(STAGING_DIR_HOST)/bin/mkdlinkfw \
+ -m $(DLINK_ROM_ID) -f $(DLINK_FAMILY_MEMBER) \
+ -F $@ \
+ -o $@.new \
+ -s $(DLINK_FIRMWARE_SIZE)
+ mv $@.new $@
+endef
+
#
# The real magic happens inside these templates
#