aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image/Makefile
diff options
context:
space:
mode:
authorSungbo Eo <mans0n@gorani.run>2020-08-05 01:03:42 +0900
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-08-08 16:13:51 +0200
commita40ddc2195350149aadbdb6077b17d4787becd9d (patch)
tree14977f6d6b1f7436851f7221568578df059608b5 /target/linux/ramips/image/Makefile
parent1bfba18a3643f2e73c7e7e7ed3cd3a350900a9cd (diff)
downloadupstream-a40ddc2195350149aadbdb6077b17d4787becd9d.tar.gz
upstream-a40ddc2195350149aadbdb6077b17d4787becd9d.tar.bz2
upstream-a40ddc2195350149aadbdb6077b17d4787becd9d.zip
ramips: adjust LZMA_TEXT_START for 32MB RAM devices
Currently the lzma-loader is placed in RAM at 32MB offset, which does not make sense for devices with only 32MB RAM. If we adjust LZMA_TEXT_START to 24MB offset, then the lzma-loader can be used on those devices and still about 24MB memory will be available for uncompressed image, which should be enough for most use cases. Signed-off-by: Sungbo Eo <mans0n@gorani.run>
Diffstat (limited to 'target/linux/ramips/image/Makefile')
-rw-r--r--target/linux/ramips/image/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/target/linux/ramips/image/Makefile b/target/linux/ramips/image/Makefile
index c0890e6bb3..f5166f8ae1 100644
--- a/target/linux/ramips/image/Makefile
+++ b/target/linux/ramips/image/Makefile
@@ -64,7 +64,7 @@ define Build/loader-common
PKG_BUILD_DIR="$@.src" \
TARGET_DIR="$(dir $@)" LOADER_NAME="$(notdir $@)" \
BOARD="$(BOARDNAME)" PLATFORM="$(LOADER_PLATFORM)" \
- LZMA_TEXT_START=0x82000000 LOADADDR=$(KERNEL_LOADADDR) \
+ LZMA_TEXT_START=0x81800000 LOADADDR=$(KERNEL_LOADADDR) \
$(1) compile loader.$(LOADER_TYPE)
mv "$@.$(LOADER_TYPE)" "$@"
rm -rf $@.src