aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image/Makefile
diff options
context:
space:
mode:
authorNOGUCHI Hiroshi <drvlabo@gmail.com>2019-07-26 08:11:48 +0900
committerPetr Štetiar <ynezz@true.cz>2019-07-26 08:09:16 +0200
commita1c6a316d2997b6bbee520fb1bf21f3b994f9e52 (patch)
tree0b883afb24d53a30bd2416ebc6e1b0c1f531b8f3 /target/linux/ramips/image/Makefile
parent5cf897779eacf63cdbcdebd1af68c109096665c6 (diff)
downloadupstream-a1c6a316d2997b6bbee520fb1bf21f3b994f9e52.tar.gz
upstream-a1c6a316d2997b6bbee520fb1bf21f3b994f9e52.tar.bz2
upstream-a1c6a316d2997b6bbee520fb1bf21f3b994f9e52.zip
ramips: add support for Fon FON2601
FON2601 is a wireless router. Specification: - SoC: Mediatek MT7620A (580MHz) - RAM: 128 MiB - ROM: 16 MiB SPI Flash - Wireless: for 11b/g/n (upto 300 Mbps): MT7620A built-in WMAC for 11a/n/ac (upto 867 Mbps): MT7662E - Ethernet LAN: 1 port, upto 100 Mbps - Ethernet WAN: 1 port, upto 1000 Mbps - USB: 1 port (USB 2.0 host) - LEDs: 4 (all can be controlled by SoC's GPIO) - buttons: 1 (Displayed as "WPS" on enclosure) - serial port: 57600n8 pins: Vcc(3.3V), Rx, Tx, GND (left to right, viewed from outside of board) Installation (only available via UART): 1. download sysupgrade binary image by wget command 2. write sysupgrade binary image to Flash command is: mtd write sysupgrade.bin firmware 3. reboot Important Notice: Only one button is displayed as "WPS" on enclosure. However, it is configured as "reset" (factory resetting feature). Signed-off-by: NOGUCHI Hiroshi <drvlabo@gmail.com> [removed unrelated openwrt-keyring revert, missing -Wall for uimage_padhdr] Signed-off-by: Petr Štetiar <ynezz@true.cz>
Diffstat (limited to 'target/linux/ramips/image/Makefile')
-rw-r--r--target/linux/ramips/image/Makefile5
1 files changed, 5 insertions, 0 deletions
diff --git a/target/linux/ramips/image/Makefile b/target/linux/ramips/image/Makefile
index 36f95b6d1c..816146ece5 100644
--- a/target/linux/ramips/image/Makefile
+++ b/target/linux/ramips/image/Makefile
@@ -147,6 +147,11 @@ define Build/sercom-footer
$(call Build/sercom-seal,-f)
endef
+define Build/fonfxcimage
+ uimage_padhdr -i $@ -o $@.new
+ mv $@.new $@
+endef
+
ifeq ($(SUBTARGET),rt288x)
include rt288x.mk
endif