aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image/Makefile
diff options
context:
space:
mode:
authorMathias Kresin <dev@kresin.me>2018-11-30 08:57:03 +0100
committerMathias Kresin <dev@kresin.me>2018-11-30 09:04:29 +0100
commit78ca6a5578d6c7b06ca520b0aac965a1babf5417 (patch)
treef69e08ae490e1d299230abd246e9f055302adf8e /target/linux/ramips/image/Makefile
parent465d57370fda8be07b3df946b7392fc435997193 (diff)
downloadupstream-78ca6a5578d6c7b06ca520b0aac965a1babf5417.tar.gz
upstream-78ca6a5578d6c7b06ca520b0aac965a1babf5417.tar.bz2
upstream-78ca6a5578d6c7b06ca520b0aac965a1babf5417.zip
ramips: merge relocate compile into build recipe
Compile the loader if the relocate-kernel image recipe is used and get rid of the legacy build code to do so. Signed-off-by: Mathias Kresin <dev@kresin.me>
Diffstat (limited to 'target/linux/ramips/image/Makefile')
-rw-r--r--target/linux/ramips/image/Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/target/linux/ramips/image/Makefile b/target/linux/ramips/image/Makefile
index 9cf64361a4..b4ff9a7492 100644
--- a/target/linux/ramips/image/Makefile
+++ b/target/linux/ramips/image/Makefile
@@ -74,12 +74,16 @@ define Build/loader-kernel
endef
define Build/relocate-kernel
+ rm -rf $@.relocate
+ $(CP) ../../generic/image/relocate $@.relocate
+ $(MAKE) -C $@.relocate KERNEL_ADDR=$(KERNEL_LOADADDR) CROSS_COMPILE=$(TARGET_CROSS)
( \
- dd if=$(KDIR)/loader.bin bs=32 conv=sync && \
+ dd if=$@.relocate/loader.bin bs=32 conv=sync && \
perl -e '@s = stat("$@"); print pack("V", @s[7])' && \
cat $@ \
) > $@.new
mv $@.new $@
+ rm -rf $@.relocate
endef
define MkCombineduImage