aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image/Makefile
diff options
context:
space:
mode:
authorChuanhong Guo <gch981213@gmail.com>2020-04-14 12:01:50 +0800
committerChuanhong Guo <gch981213@gmail.com>2020-04-14 12:01:50 +0800
commit75f19deb3a0111afde83f5ca4aae4429c2ea9865 (patch)
tree384cf8278dc16fdb3b6124ebe0635fa31a5d4e96 /target/linux/ramips/image/Makefile
parentd9e9a0e6b11aa461aef1a030e5782292afb58338 (diff)
downloadupstream-75f19deb3a0111afde83f5ca4aae4429c2ea9865.tar.gz
upstream-75f19deb3a0111afde83f5ca4aae4429c2ea9865.tar.bz2
upstream-75f19deb3a0111afde83f5ca4aae4429c2ea9865.zip
ramips: define image recipe for uncompressed uimage with loader
Some devices have bootloaders with broken lzma code resulting in failed decompression or corrupted kernel code. This image recipe allows to sacrifice 5KB for OpenWrt LZMA loader and take over the task of decompress kernel. Signed-off-by: Chuanhong Guo <gch981213@gmail.com>
Diffstat (limited to 'target/linux/ramips/image/Makefile')
-rw-r--r--target/linux/ramips/image/Makefile5
1 files changed, 5 insertions, 0 deletions
diff --git a/target/linux/ramips/image/Makefile b/target/linux/ramips/image/Makefile
index bc5de7d8d0..a966ba4349 100644
--- a/target/linux/ramips/image/Makefile
+++ b/target/linux/ramips/image/Makefile
@@ -37,6 +37,11 @@ define Device/Default
IMAGE/sysupgrade.bin := append-kernel | append-rootfs | pad-rootfs | append-metadata | check-size
endef
+define Device/uimage-lzma-loader
+ LOADER_TYPE := bin
+ KERNEL := $(KERNEL_DTB) | loader-kernel | uImage none
+endef
+
define Device/seama
SEAMA_MTDBLOCK := 2
IMAGES += factory.bin