aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image/Makefile
diff options
context:
space:
mode:
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>2019-07-15 14:55:02 +0200
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2019-07-25 14:31:01 +0200
commit7392af752042337c99fd07dd7a7d75db5c6cd59b (patch)
treecf8929c4129420d40bec6bebcbea7b7491850139 /target/linux/ramips/image/Makefile
parentb9cf1f60811730a54c918d1118725e88e29e0950 (diff)
downloadupstream-7392af752042337c99fd07dd7a7d75db5c6cd59b.tar.gz
upstream-7392af752042337c99fd07dd7a7d75db5c6cd59b.tar.bz2
upstream-7392af752042337c99fd07dd7a7d75db5c6cd59b.zip
ramips: fix ralink_default_fw_size_16M
In ramips, there are the following predefined values for IMAGE_SIZE ralink_default_fw_size_4M 3866624 3776k 0x3B0000 ralink_default_fw_size_8M 8060928 7872k 0x7B0000 ralink_default_fw_size_16M 16121856 15744k 0xF60000 ralink_default_fw_size_32M 33226752 32448k 0x1FB0000 Out of those, the "16M" value is obviously odd, as it provides more room for the remaining partitions than the tree others. Of the devices in all subtargets, there are actually > 50 that have a firmware partition with 0xFB0000 size, while only 5 (!) have 0xF60000. From the former, many are set to ralink_default_fw_size_16M anyway, although it is wrong at the present point. Consequently, it makes sense to change ralink_default_fw_size_16M to 0xFB0000, and to update IMAGE_SIZE for the 5 devices with 0xF60000. Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
Diffstat (limited to 'target/linux/ramips/image/Makefile')
-rw-r--r--target/linux/ramips/image/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/target/linux/ramips/image/Makefile b/target/linux/ramips/image/Makefile
index 181c825873..b1f0612941 100644
--- a/target/linux/ramips/image/Makefile
+++ b/target/linux/ramips/image/Makefile
@@ -150,7 +150,7 @@ endef
ralink_default_fw_size_4M=3866624
ralink_default_fw_size_8M=8060928
-ralink_default_fw_size_16M=16121856
+ralink_default_fw_size_16M=16449536
ralink_default_fw_size_32M=33226752
ifeq ($(SUBTARGET),rt288x)