aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image/Makefile
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2015-02-16 21:19:18 +0000
committerJohn Crispin <blogic@openwrt.org>2015-02-16 21:19:18 +0000
commit6b1d5b906cefd016ce9dea7d02b0b68a1b59d1c4 (patch)
tree86c81663df0830784734bc4705ffef1436036ce7 /target/linux/ramips/image/Makefile
parent2cb7799ed48f16f63f5de58dbe5e9e0c6981e687 (diff)
downloadupstream-6b1d5b906cefd016ce9dea7d02b0b68a1b59d1c4.tar.gz
upstream-6b1d5b906cefd016ce9dea7d02b0b68a1b59d1c4.tar.bz2
upstream-6b1d5b906cefd016ce9dea7d02b0b68a1b59d1c4.zip
ramips: Buffalo WZR-AGL300NH target support
I got work with this patch. Ethernet switch (includes VLAN), WiFi connected via PCIe, LEDs, buttons. In mtd partion map of DTS file, I renamed Linux firmware regions (kernel + root squashfs) to “firmware”because it allows kernel to split kernel and roots and rootfsdata. signed-off-by: ngc@ff.iij4u.or.jp —— —— git-svn-id: svn://svn.openwrt.org/openwrt/trunk@44470 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ramips/image/Makefile')
-rw-r--r--target/linux/ramips/image/Makefile3
1 files changed, 3 insertions, 0 deletions
diff --git a/target/linux/ramips/image/Makefile b/target/linux/ramips/image/Makefile
index 73637300fd..6e6b10bd46 100644
--- a/target/linux/ramips/image/Makefile
+++ b/target/linux/ramips/image/Makefile
@@ -395,6 +395,8 @@ Image/Build/Profile/V11STFE=$(call BuildFirmware/Default4M/$(1),$(1),v11st-fe,V1
Image/Build/Profile/WLITX4AG300N=$(call BuildFirmware/Default4M/$(1),$(1),wli-tx4-ag300n,WLI-TX4-AG300N)
+Image/Build/Profile/WZRAGL300NH=$(call BuildFirmware/Default4M/$(1),$(1),wzr-agl300nh,WZR-AGL300NH)
+
ifeq ($(SUBTARGET),rt288x)
define Image/Build/Profile/Default
$(call Image/Build/Profile/AR670W,$(1))
@@ -403,6 +405,7 @@ define Image/Build/Profile/Default
$(call Image/Build/Profile/RTN15,$(1))
$(call Image/Build/Profile/V11STFE,$(1))
$(call Image/Build/Profile/WLITX4AG300N,$(1))
+ $(call Image/Build/Profile/WZRAGL300NH,$(1))
endef
endif